OK, I have fix for the Geforce, OpenGL and Quake2 problem.
Please note that this worked for me with my Spec and has not been tested with any other
Specifications or Hardware Situations. I may try installing the Detonator Drivers again at some
point, following the proceedures below, but at the moment I have my system running again, so I
don't plan to rush into anything
This solution doesn't get Quake3 working for me... BUT it now fails to run because of reasons
OTHER THAN OpenGL failure

Specifications
-------------
Hardware:
PIII 650e, 128M Ram, 20G HD, Geforce DDR on Primary Monitor, SIS 4M on Secondary Monitor,
SBLive!, Motherboard Irrelevant since everything worked before the new drivers were installed.

Software:
Windows 2000 Professional, Quake2, Quake3, UT.

Original Drivers: W2k-378.zip
Updated Drivers: W2k-522.zip and dnv3d-2k-522.exe (tried both)

Background
-----------
The system worked perfectly with the 378 drivers, but the installation of the 522 Detonators
totally screwed things up as follows:
Primary Monitors screen position shifted.
Q2 - OpenGL Failed with GL_context failure.
Q3 - OpenGL Failed with GL_context failure.
UT under D3D - uneffected
OpenGL screensavers - uneffected

Solution
--------
I reinstalled my original 378 drivers without success on 2 occasions, until I hit on this solution. It all
revolves around the Registry cleaning proceedure, which isn't fully reported on some sites I looked
at!
Follow these steps:

1. Uninstall the NVidea drivers in the usual way from Control Panel Add/Remove Programs.
2. Delete the Video card from Control Panel/Hardware/Device Manager/Display Adapters.
3. Delete the Monitor for that card from Control Panel/Hardware/Device Manager/Display Adapters.
4. Delete the directory containing the Nvidea Drivers so you only have the original zip or
executable installer. (in my case that's W2K-378.zip)
5. Restart Windows 2000.
6. When Hardware Wizard finds the new device on startup, click Cancel to abort the new hardware
installation.
7. Go to the Windows Registry (Start/run/regedit) and Export the file to the desktop as a backup.
Then, using Edit/Find, track down and delete ALL references to NVidea by searching for the
following:
Keys: nvidea, nvid, nv4 (Delete ALL keys found)
Values and data: nvidea, nvid, nv4 (Delete ALL data found)
This may take a while, but YOU MUST DO IT !
8. Close regedit.
9. Unzip the driver from W2K-378.zip to a directory of your choice.
10. Restart Windows 2000.
11. When the Hardware Wizard detects the new Geforce Card, click next and follow the install
proceedure, pointing at the drivers you unzipped.
12. Setup the previously deleted monitor in Control Panel/Hardware/Device Manager/Display
Adapters. (Plug and Play in my case)
12. Make sure you now disable multiple monitors from Control Panel/Display Properties/Settings to
leave ONLY the Geforce as the active card (i.e. ONLY one functionaing monitor on the system)
13. Go to your Quake2 Directory and delete quake2/config.cfg and quake2/baseq2/config.cfg to
force Q2 to setup new video settings.
14. Run Quake2 with Default OpenGL video settings to make sure it's OK again with single monitor
support.
15. Delete your secondary Video card from Control Panel/Hardware/Device Manager/Display
Adapters.
16. Restart Windows 2000.
17. When Hardware Wizard finds the new Card, install it in the normal way.
18. Restart Windows 2000.
19. Re-enable multiple monitors from Control Panel/Display Properties/Settings. (You should now
have the Geforce on the Primary Monitor and the other card on the Secondary Monitor)
20. Run Quake2 on your Geforce with other stuff on the secondary monitor and jump around for
joy!

Bidmix