Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Search:

Type: Posts; User: bonsalty

Search: Search took 0.00 seconds.

  1. Meanwhile I checked versions and seems that only...

    Meanwhile I checked versions and seems that only openGL 1.1 is added to win7, wondering why it doesnt get updated with the graphics driver install.
  2. - GL_ARB_vertex_buffer_object - not recognoized on some win7 systems

    Greetings, need some help, ideas!

    I am working on a project , building 3D pipeline models for the waterworks, it uses opengl, freeglut , glew. It is working excelent on many
    computers including...
  3. Re: Bug?- glGenBuffer reassigns IDs in vector

    Thanks, I didnt post the solution , but this is exactly what I did and it fixes the problem , using vector< class pointer > instead of just vector <class>. Besides this is a c++ vector pitfall its...
  4. Re: Bug?- glGenBuffer reassigns IDs in vector

    PROBLEM SOLVED:
    Ok I think I found the problem, its nothing with VBO its a fun with vector memory allocation. The folowing thing happens in this code:

    for (int i=0;i<10;i++){
    ...
  5. Re: Bug?- glGenBuffer reassigns IDs in vector

    No sorry, pipelines.pushback was type mismatch in my code its ok:
    push_back.
    I replaced everything to glew, its not working either, the same issue.
    I dont use any threads.
  6. Re: Bug?- glGenBuffer reassigns IDs in vector

    Thanks for your response.
    a)Well, I didnt mention , Im using freeglut for windowing if this counts.
    b)Yes I bind those before drawing. I think my code is just right,
    but Windows is messing up...
  7. Bug?- glGenBuffer reassigns IDs in vector

    Im using VBO for fast rendering, now I have an issue I cant solve:
    glGenBuffer is behaving idiotic when assigning IDs for the vector<MyClass> objects. I get always the same values for normalsID,...
Results 1 to 7 of 7