Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Search:

Type: Posts; User: MagnumOpus

Search: Search took 0.00 seconds.

  1. Thread: VBOs slow?

    by MagnumOpus
    Replies
    2
    Views
    1,540

    VBOs slow?

    Okay, so I've been trying to find the cause of a reported slowdown with something I work on. I'm a hobby programmer and I work on a faster, better engine for a Half-Life mod, and I mostly do my...
  2. Replies
    2
    Views
    729

    Thanks for your response, but eventually I found...

    Thanks for your response, but eventually I found out that it wasn't the cause. I'll post another thread.
  3. Replies
    2
    Views
    729

    Strange OGL Behaviour

    Hey everyone.

    I'm programming graphics for a HL mod, and I've bumped into a weird issue after a major optimization went down, and I don't see why this happens in the first place. It seems that for...
  4. Thread: VSM issues

    by MagnumOpus
    Replies
    6
    Views
    1,235

    Alright, I figured out my issues. I was...

    Alright, I figured out my issues. I was transforming the depth coord in the fragment shader to the 0-1 range, even though I was already doing that. And my precision issue at distance is caused by the...
  5. Thread: VSM issues

    by MagnumOpus
    Replies
    6
    Views
    1,235

    I did that, actually quite a few times over the...

    I did that, actually quite a few times over the course of this. I've been banging my head against this wall for a while, I went through numerous revisions back to the old PCF filtered method, which...
  6. Thread: VSM issues

    by MagnumOpus
    Replies
    6
    Views
    1,235

    Thanks for your response. I use RGBA16_ARB as the...

    Thanks for your response. I use RGBA16_ARB as the internal format, so when I store the moments I have to encode them in the 4 components, and later when I use them I have to restore it. This can't be...
  7. Thread: VSM issues

    by MagnumOpus
    Replies
    6
    Views
    1,235

    VSM issues

    Hey.

    I'm asking for help with my implementation of variance shadow mapping. I'm using Cg to compile down to ARB shaders, and almost everything seems to be working fine, apart from some fine-tuning...
  8. Replies
    0
    Views
    595

    arb_fragment_program_shadow and AMD

    So I searched all over the internet for this, and haven't found many answers. I'm using ARB shaders in my code for pure convenience, I don't work much with more expensive shading and for...
  9. Replies
    7
    Views
    1,403

    Yeah, I really need to get rid of this old...

    Yeah, I really need to get rid of this old system, but until lately it wasn't a problem, since I barely played any new games and I mostly just modded GoldSrc as a hobby, but now that I experimented...
  10. Replies
    7
    Views
    1,403

    Alright, I've been doing tests, and came to the...

    Alright, I've been doing tests, and came to the conclusion that my video card is absolute junk. I've been trying everything to get this problem fixed, but not even running the exact same drawing...
  11. Replies
    7
    Views
    1,403

    Thanks for the fast reply. I wrote all of my...

    Thanks for the fast reply. I wrote all of my shaders in ARBfp1.0/ARBvp1.0 and I load all of them straight from the code at initialization. I don't think ARBfp/vp the issue, as I am having the same...
  12. Replies
    7
    Views
    1,403

    Initial lag with shaders?

    Hey there, I'd like to ask for your help.

    I'm encountering a rather odd phenomena with my shaders. I noticed it first that sometimes, the game I worked on had been randomly lagging up, when I'd...
Results 1 to 12 of 12