Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Search:

Type: Posts; User: Jnanadeva

Search: Search took 0.00 seconds.

  1. Replies
    2
    Views
    799

    Thank you very much for the comprehensive reply....

    Thank you very much for the comprehensive reply. I wasn't quite sure about mixing different attachments but your implication



    ensured me that my assumptions were correct.
  2. Replies
    2
    Views
    799

    Framebuffer depth attachments

    I have a bit of a problem refactoring my deferred renderer.

    I used two separate FBO: one for rendering the g-buffer and the other one to render the shadow-maps. Now I try to get rid of the second...
  3. Replies
    2
    Views
    698

    OK found the problem, it was burried very...

    OK found the problem, it was burried very elsewhere and VERY hard to track...
    I'm using program-introspection to retrieve all uniform-fields in a program and store them in a program-class at load...
  4. Replies
    2
    Views
    698

    I was able to remove the subroutines from the...

    I was able to remove the subroutines from the geometry-shader but introduced some in the vertex-shader, again the same result. What I am ultimatively try to achieve is to render a shadow cube-map in...
  5. I would not mind so much about performance in the...

    I would not mind so much about performance in the beginning of the deferred shading and throw in as much g-buffers as you need. When your material-system is finished then you can try to pack and...
  6. I'm using a plain uniform mat4 u_bones[...

    I'm using a plain
    uniform mat4 u_bones[ MAX_BONES_PER_MESH ]; for the bones and the vertex-specific stuff comes through the vertex-stream.
    Is a uniform-buffer faster than a uniform matrix-array...
  7. Replies
    2
    Views
    698

    EmitVertex in Subroutines

    I'm writing a Geometry-Shader where subroutines are used but it seems that a call to EmitVertex in a subroutine seems not to work - I get no visual output. On the opposite when I make the call to...
Results 1 to 7 of 7