Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Search:

Type: Posts; User: pjcozzi

Page 1 of 8 1 2 3 4

Search: Search took 0.00 seconds.

  1. Replies
    10
    Views
    5,006

    Re: Depth texture bound to FBO and texture unit?

    Thanks everyone for the input.

    Just to clarify my original question: I have an FBO with a texture depth attachment. I issue two draw calls when the FBO is bound: the first has depth writes and...
  2. Replies
    10
    Views
    5,006

    Depth texture bound to FBO and texture unit?

    Hi,

    Is it possible to have a depth texture bound to a texture unit for reading in a fragment shader and also have the depth texture assigned to an FBO's depth attachment as long as depth writes...
  3. glGetTransformFeedbackVarying on ATI and NVIDIA

    Hi,

    When glGetTransformFeedbackVarying returns information about gl_Position, I get different values for its size on ATI and NVIDIA. On ATI, the size is 4; on NVIDIA, it is 1. In both cases, the...
  4. Replies
    11
    Views
    3,520

    Re: PBO/textures on ATI

    I just tried Catalyst 10.12 and still experience the issue.

    Thanks,
    Patrick
  5. Replies
    27
    Views
    13,789

    Re: gDEBugger is free!!!

    I ran into these crashes using an ATI card. I tried gDEBugger today on an NVIDIA card and it appears quite stable.

    Patrick
  6. Replies
    6
    Views
    3,008

    Re: Help with ray casting - near plane

    Consider rendering only the back faces of the cube. When only the front faces are rendered, no fragments (and thus no rays) are generated when the viewer enters the cube.

    Regards,
    Patrick
  7. Replies
    27
    Views
    13,789

    Re: gDEBugger is free!!!

    I saw this messages too. In my case, I believe it is because the pointer argument is 0. gDebugger is right that 0 wasn't generated with glGen*(), but it is still a valid value to pass to...
  8. Replies
    11
    Views
    3,520

    Re: PBO/textures on ATI

    I will retest when this driver is available. Thanks.

    I assume you mean 2^23 bytes. It looks like it is not a problem with all textures greater than this size because all my textures are larger...
  9. Replies
    11
    Views
    3,520

    PBO/textures on ATI

    Hi,

    I have some PBO/texture code that works on NVIDIA but not ATI. On NVIDIA, the scene looks like:

    http://miniglobe.sourceforge.net/ATI/Correct.png

    On ATI, it looks like the alignment is...
  10. Replies
    21
    Views
    8,489

    Re: Using glTexImage2D with null data

    I disabled texture logging in GLIntercept and no more errors are generated so that was definitely the problem. GLIntercept is really configurable. I like it.

    Patrick
  11. Replies
    21
    Views
    8,489

    Re: Using glTexImage2D with null data

    I bet you are right. Even a call to glDeleteTextures right after glTexImage2D reports an invalid operation. I'm not quite sure why glGetTexImage would generate the error though. I even tried...
  12. Replies
    10
    Views
    3,522

    Re: A Radeon 5800 as if it was a Radeon 4800?

    I'm glad you like it. My immediate goal is just to report the system's OpenGL capabilities without requiring administrator privelages or an actual install (I suppose the applet is installed). If...
  13. Replies
    21
    Views
    8,489

    Re: Using glTexImage2D with null data

    I am using GLintercept.

    I just ran without GLintercept, and added a glGetError after the offending glBindTexture, and it returned GL_NO_ERROR. I also checked the offending glTexSubImage2D call,...
  14. Replies
    21
    Views
    8,489

    Re: Using glTexImage2D with null data

    No, these are some of the first GL calls in the application.


    Good question. It happens with or without a null pointer. Strangely, I can narrow it down to this:


    ...
  15. Replies
    21
    Views
    8,489

    Re: Using glTexImage2D with null data

    lol. You and me both.

    Patrick
  16. Replies
    21
    Views
    8,489

    Re: Using glTexImage2D with null data

    Yeap. The calls are basically back to back in this case.


    I was trying to keep my post short, but perhaps I am hiding the problem by doing so. Here is more output from GLIntercept:


    I am...
  17. Replies
    21
    Views
    8,489

    Re: Using glTexImage2D with null data

    That is what I thought. Thanks!

    Patrick
  18. Replies
    21
    Views
    8,489

    Re: Using glTexImage2D with null data

    Funny, I actually have calls to glTexParameteri right after glTexImage2D. I moved them to before as you suggested:



    glTexParameteri(GL_TEXTURE_2D,GL_TEXTURE_MIN_FILTER,GL_LINEAR);...
  19. Replies
    21
    Views
    8,489

    Using glTexImage2D with null data

    Hi,

    I am using glTexImage2D to allocate texture memory, then later specifying the image with glTexSubImage2D, as we discussed a while back. Everything has been working fine, except I've...
  20. Re: GL_INVALID_OPERATION in glVertexAttribPointer

    Good eye. I thought the VAO may have something to do with it, but I expected to see VAO restrictions in the SDK page for glVertexAttribPointer. Next time, I'll check both.

    Thanks!
    Patrick
  21. GL_INVALID_OPERATION in glVertexAttribPointer

    Hi,

    glGetError returns GL_INVALID_OPERATION after the following sequence:



    glBindVertexArray(1);
    glDisableVertexAttribArray(1);
    glBindBuffer(GL_ARRAY_BUFFER,0);...
  22. Replies
    9
    Views
    4,075

    Re: Explicit Attribute Location on ATI

    Update: ATI confirmed this as a bug and said they are working on it.

    Patrick
  23. Replies
    9
    Views
    4,075

    Re: Explicit Attribute Location on ATI

    Good to know. Thanks. I'll send an email to devrel@amd.com.

    Patrick
  24. Replies
    9
    Views
    4,075

    Re: Explicit Attribute Location on ATI

    This is certainty one option, and I'll do it if I have to (or perhaps, if there is a performance advantage), but being able to assign arbitrary vertex locations is nice for software design. You can...
  25. Replies
    9
    Views
    4,075

    Re: Explicit Attribute Location on ATI

    Good call Alfonse. I am using GL 3.3 core profile. glGetString(GL_VERSION) returns:

    "3.3.10243 Core Profile Forward-Compatible/Debug Context"

    Also, when I switch the locations from 1 and 2 to...
Results 1 to 25 of 196
Page 1 of 8 1 2 3 4