Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Search:

Type: Posts; User: BanskiAchtar

Search: Search took 0.00 seconds.

  1. I see. Ultimately I will end up rendering the...

    I see. Ultimately I will end up rendering the original texture onto a new texture, and then read the pixels from the new texture. This will sidestep the issue (since I will never render using the...
  2. Sorry, I am not completely sure what you mean by...

    Sorry, I am not completely sure what you mean by this.
  3. Hmm, I'm still thinking about this answer--it...

    Hmm, I'm still thinking about this answer--it doesn't quite match up with what I'm doing, but maybe you are on to something. Just to be clear, I'm never rendering to a texture which is attached to...
  4. Thanks for the suggestion; I did try...

    Thanks for the suggestion; I did try gl.glReadBuffer(GL2.GL_NONE) before and/or after the "detach texture" line. It has no observable effect.

    Also, I tried running this project in Windows 7 (with...
  5. Attaching texture to framebuffer for reading causes slow rendering later

    Some context: I have a project which creates thumbnails of textures when they are loaded to be used in the GUI. This is achieved by attaching the texture to a framebuffer and using glReadPixels. ...
  6. Re: Strange link error when using samplerCube

    That makes sense, I suspected that was the case but it's good to know for sure. Thanks for the help!
  7. Re: Strange link error when using samplerCube

    Whoops, I guess I should have checked if it was a link error or validation error! You nailed it exactly... I rewrote all the error checks more carefully, separating the link and validation checks,...
  8. Re: Strange link error when using samplerCube

    Ok, just to be really complete, here are more glGetStrings:

    GL_SHADING_LANGUAGE_VERSION: 4.20

    GL_EXTENSIONS: GL_AMDX_debug_output GL_AMDX_vertex_shader_tessellator GL_AMD_conservative_depth...
  9. Re: Strange link error when using samplerCube

    Here's another piece of code that might be relevant: The TEXTURE_CUBE_MAP I'm rendering to is created like this:



    //create texture
    int[] createTexIDs = new int[1];...
  10. Strange link error when using samplerCube

    This is a little long but I want to be as clear as possible.

    Here is a brief description of my problem: I am successfully rendering a simple scene using deferred shading and light maps. ...
Results 1 to 10 of 10