Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Search:

Type: Posts; User: Silverlan

Search: Search took 0.00 seconds.

  1. I've tried it with various different values,...

    I've tried it with various different values, 0.25, 0.75, 0.18, etc, the result is always '64' for all pixels.


    I have an AMD card and it's working fine, but thanks, I'll remember that.
  2. I had the compare function set to GL_LEQUAL, but...

    I had the compare function set to GL_LEQUAL, but apparantly I forgot to actually enable it. The parameters are now:


    glTexParameteri(GL_TEXTURE_2D_ARRAY,GL_TEXTURE_MIN_FILTER,GL_NEAREST);...
  3. Hm... Still having a bit of trouble with the...

    Hm... Still having a bit of trouble with the shader.
    Using glClear works as expected now:


    glClearColor(0.f,0.f,0.f,0.75f);
    glClear(GL_COLOR_BUFFER_BIT);
    glClearColor(0.f,0.f,0.f,1.f);...
  4. Well I'll be damned. The scissor test was the...

    Well I'll be damned. The scissor test was the problem, I still had it active from a different test.
    Thank you.

    // Edit:
    Well, the glClear-Call works now, but still no luck when trying to render...
  5. Cascaded shadow mapping - Texture lookup and depth comparison

    I'm trying to implement cascaded shadow mapping in my game engine, but I'm somewhat stuck at the last step. For testing purposes I've made sure all cascades encompass my entire scene. The result is...
  6. Can't draw to the alpha component of a single channel texture after creation

    My texture has a single channel only, however I can't seem to change its contents other than at the time of creation:


    glDisable(GL_DEPTH_TEST);
    unsigned int frameBuffer;...
  7. I do have AMD hardware, yeah, but changing the...

    I do have AMD hardware, yeah, but changing the order didn't help. Strangely enough with the order you've given me it still only rendered the top image (+y).
    I will try it again tomorrow as an...
  8. The lines you've mentioned are throwing a...

    The lines you've mentioned are throwing a GL_INVALID_ENUM error, but as you've said, that's to be expected.
    No other errors before that.
    Is there any way to check if the buffer actually has an...
  9. I figured someone may have had a similar issue,...

    I figured someone may have had a similar issue, but alright.
    Loading the images:

    const GLenum cubemapTargets[6] = {
    GL_TEXTURE_CUBE_MAP_POSITIVE_Y, // Top
    GL_TEXTURE_CUBE_MAP_NEGATIVE_X, //...
  10. Skybox (Cubemap) - Only first loaded image is stored in texture buffer

    Hey,

    I've been trying to implement a simple skybox in my program, which seemed fairly straight forward, but I've run into some trouble.
    The shaders seem to be correct, but for whatever reason...
  11. Using the same texture buffer multiple times with different parameters

    Hey,

    I have a texture which I'm using at multiple instances throughout my program.
    At each instance I'm applying different texture parameters, which would effectively overwrite each other and...
  12. Replies
    3
    Views
    1,000

    Thanks, I've changed that. ...

    Thanks, I've changed that.

    glEnableVertexAttribArray(3);
    glBindBuffer(GL_ARRAY_BUFFER,buf);
    glVertexAttribIPointer(
    3,
    4,
    GL_INT,
    0,
    (void*)0
  13. Replies
    3
    Views
    1,000

    [C++] Passing array to opengl

    I don't have much experience with glsl yet and I've run into a problem I can't figure out.
    I have an array that contains 4 integer values for each vertex of my mesh.
    Since these values never...
  14. Well, that's embarrassing... I found the source,...

    Well, that's embarrassing...
    I found the source, it was due to a uninitialized variable.
    Thread can be closed.
  15. Rendering problems with release configuration [C++] [VS2010] [GLFW]

    I'm using GLFW and everything has been working fine, as long as I'm using the debug configuration in VS2010.
    When switching to release, everything's still fine in the debugger. However, when I try...
Results 1 to 15 of 15