Is OpenGL verison 4.2 backwards compatible with version 2.0?