Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Search:

Type: Posts; User: bladematthewslp

Search: Search took 0.00 seconds.

  1. Replies
    8
    Views
    1,172

    I actually got this to work finally. Using...

    I actually got this to work finally. Using #version 400, I completely took out the layout(location=0) parts because my hardware does not support that....so I just declare my variables as

    in vec2...
  2. Replies
    8
    Views
    1,172

    Malexander, when I tried what you recommended...

    Malexander, when I tried what you recommended using version 330, the following error shows in the vertex shader compiler: "ERROR: 0:2: 'location' : syntax error parse error".
  3. Replies
    8
    Views
    1,172

    I figured out how to get shader compiler errors....

    I figured out how to get shader compiler errors.

    I didn't get any errors with my fragment shader. However, the vertex shader compiler returned this error when I ran it using version 330 (It...
  4. Replies
    8
    Views
    1,172

    Also, I do not get an error in VS2010. If there...

    Also, I do not get an error in VS2010. If there is somewhere else I should look for a "shader compiler error", please tell me where I can find that.
  5. Replies
    8
    Views
    1,172

    Does that mean I need to change the version in my...

    Does that mean I need to change the version in my shader to 330 or higher? It used to be a 430 as I was following a tutorial I found online, but I lowered it to 140 when I saw another forum post say...
  6. Replies
    8
    Views
    1,172

    Trouble with shader

    I'm having some problems getting my shader to work and I seek guidance, please.

    When I run the code below, the triangles that I output is white and not the color specified in verts[] at the end of...
Results 1 to 6 of 6