Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Search:

Type: Posts; User: LReiter

Search: Search took 0.00 seconds.

  1. Replies
    9
    Views
    810

    I'm having a problem understanding why the error...

    I'm having a problem understanding why the error might be in the obj file. I just exported it from Blender, when I re-import it it looks just fine.
    The file does have a different number of data sets...
  2. Replies
    9
    Views
    810

    Do I really need a VAO? I never used them before,...

    Do I really need a VAO? I never used them before, and many of the tutorials I've seen online don't mention them.

    edit: I don't think I do, do I? I've gotten my code to the point now where the...
  3. Replies
    9
    Views
    810

    Hey thanks I'll try it! From my understanding...

    Hey thanks I'll try it!
    From my understanding though. shouldn't it be "final_vertices.size() / sizeof(GLfloat)" instead of "final_vertices.size() * sizeof(GLfloat)"? Alas, if your proposal doesn't...
  4. Replies
    9
    Views
    810

    VBOs and elements issue

    Hey all,

    I'm trying to optimize my program to a relatively modern openGL standard. In that interest, I'm trying to write a class for 3D objects with a model and texture loading function (with...
  5. Well, just to let anyone who's interested know -...

    Well, just to let anyone who's interested know - After renaming the variable and rewriting my shader (maybe I wasn't really using it after all and the use was optimized out anyway) I have no more...
  6. Yeah, I have glGetAttribLocation() calls for...

    Yeah, I have glGetAttribLocation() calls for other variables (coord3d,...) in the shader right before the glGetUniform(). These work just fine. The shaders link and compile successfully as well, I'm...
  7. glGetUniformLocation returns -1 with sampler2D

    Hey everyone,

    I'm trying my hand at using textures in openGL. Currently, I'd like to get a hold of the uniform handle of my sampler2D variable.
    The code is:

    qDebug() << "glGetError before...
  8. Replies
    5
    Views
    752

    Thank you guys. I now have an ok lighting...

    Thank you guys. I now have an ok lighting situation. I'm not using the normals from the OBJ file at all now but rather have the vertex shader like this:

    attribute vec3 coord3d;
    attribute vec3...
  9. Replies
    5
    Views
    752

    Thanks a lot for the help. I read the tutorial...

    Thanks a lot for the help. I read the tutorial you linked to but have trouble understanding where to provide said matrix.
    Also, when I try the

    attribute_v_normal = glGetAttribLocation(program,...
  10. Replies
    5
    Views
    752

    Finally getting my normals to work

    Hello everyone!

    What I'm trying to do is using the normals I got from an obj file. I recently had to re-code large parts of my program to accomodate new standards. Before I did this, the normals...
  11. Replies
    0
    Views
    510

    Wrong framebuffer rendered to screen

    Hey guys,
    I have a teeny tiny problem with marrying my openGL application and the Oculus Rift. Since it's an openGL problem, I thought I might as well ask here.
    To those who might not be familiar,...
  12. Do you mean glUseProgram()? I'm doing that. It's...

    Do you mean glUseProgram()? I'm doing that. It's basically

    glUseProgram(gl_fragment_shader_program);
    glActiveTexture(GL_TEXTURE0);
    glBindTexture(GL_TEXTURE_2D,...
  13. Thanks very much so far. :) Excuse my...

    Thanks very much so far. :) Excuse my tediousness. ;)
    The shaders are stored in strings:

    const char* gl_vertex_shader_code =
    "#version 330 core\n"
    "\n"
    "layout(location = 0) in vec3...
  14. glGetUniformLocation always causes GL_INVALID_VALUE

    Hey everyone,
    I'm trying to get my openGL code to work with the Oculus Rift.
    I'm using a (slightly) modified version of this code, particularly regarding the shaders.
    However, the calls to...
  15. glutSolidSphere won't work after updating IDE

    Hi everyone,
    I recently updated to Qt5.1.1 from Qt5.0.2. Since I did this, my formerly fine working code mysteriously doesn't do what it's supposed to anymore.
    Basically I'm displaying...
  16. Well, for now I decided to not focus on the...

    Well, for now I decided to not focus on the double buffering (might as well do it as soon as I get the "simpler" way to work, I think).
    My problem is still that I'm initializing the array of spheres...
  17. Okay, thanks for the tip, but adding...

    Okay, thanks for the tip, but adding
    glutInitDisplayMode(GLUT_DOUBLE);
    in my initializeGL() function and
    glutSwapBuffers();
    in my paintGL() function simply causes the program to crash.
    After...
  18. Thank you. A swapBuffers() call as well as a...

    Thank you. A swapBuffers() call as well as a SwapBuffers(hDC) call will result in a completely black background (as opposed to my default glClearColor() grey). I think I'm only drawing in one buffer...
  19. Thanks for the tip! However, if I call the...

    Thanks for the tip! However, if I call the constructor with an 'r', it does produce a red sphere.
    I also attached a qDebug to the drawSphere() function to see which color sphere is drawn when.
    It...
  20. Drawing a sphere and recoloring and/or deleting it

    Hey all,
    for an university project I am trying to write a program that shows a couple of white spheres that turn red one by one, each time the mouse is clicked. However, I can't get it to work...
Results 1 to 20 of 20