PDA

View Full Version : Integration Eclipse, QT and OpenGL



MaxMarkson
08-14-2012, 01:23 AM
Hi all, I've a problem with QT and OpenGL in the IDE Eclipse.
I've downloaded the QT plugin for Eclipse and it works fine.
I made some projects with OpenGL and even these work fine.
The problem born when I try to put together QT an OpenGL

I choose to create a new QT project: File -> New -> QT Gui Project, assign a name and choose QMainWindow as UI Type. I import modules Core, Gui and OpenGL.

Here still no problem; when I try to follow this tutorial (http://www.cs.tufts.edu/comp/175/support/Tutorial.pdf) and I make the calls to the OpenGL functions I've a lot of errors like Type 'glShadeModel' could not be resolved.

This is my .pro file:


TEMPLATE = app
TARGET = ProvaQTGL2
QT += core \
gui \
opengl
HEADERS += MyPanelOpenGL.h \
provaqtgl2.h
SOURCES += MyPanelOpenGL.cpp \
main.cpp \
provaqtgl2.cpp
FORMS += provaqtgl.ui
RESOURCES +=


Where ProvaQTGL2 is the name of the project and MyPanelOpenGL is a calss that I created following the tutorial, it extends the class QGLWidget and it's used to call OpenGL's functions and draw the figure
I'm developing with QT 4.8.2 and Windows 7
Here you can find the project (http://www.mediafire.com/?4qgr65iat2ady1i)

Any suggestion?

Thanks a lot, Massimo