PDA

View Full Version : Weird performance issues



craterz
02-28-2012, 07:28 AM
Right now my game runs at about 220 fps on machines with nvidia cards and 40fps on machines with significantly better amd cards. are there any common causes of this? ive tried display lists and VBOs and both yield similar results.

Zyx_2000
02-28-2012, 10:24 AM
First, don't measure performance in FPS, use frame time instead, see this wiki page (http://www.opengl.org/wiki/Performance) for more information.

Second, it is likely that the GPU is not the bottleneck. What other hardware do the machines you've tested on have?

craterz
02-28-2012, 02:28 PM
I've personally tested on one computer and my friend has tested on 3.

My computer:Nvidia GTX 460m, 2.0 ghz i7 processor
-frame time around .0041
Friend's laptop: realtively new, decent nvidia card
-frame time around .0045
Friend's main computer: AMD cpu much better than mine, AMD 5670
-frame time around .025
Other computer: also much better cpu, comparable AMD card to friends computer but not the same.
-frame time around .025

Sorry i dont have specifics on my friend's computers, going off what I remember.

Alfonse Reinheart
02-28-2012, 04:40 PM
There's no way for us to know without code. Any number of things could be causing a performance issue. Or it could be entirely due to other issues than your code.

craterz
02-28-2012, 05:39 PM
yeah im not asking you all to debug a whole program for me. I was just wondering if there were any common quirks that would cause code to run decently on one vendor's card and not the other.

ZbuffeR
02-29-2012, 01:56 AM
Do you check for GL_ERROR ?
At one time Nvidia disabled reporting GL errors by default in drivers, supposedly to gain a few percent in some benchmark. It can be changed in the nvidia control panel. It would probably only make a change if your code generates a lot of GL errors.