PDA

View Full Version : An issue with OpenGL on my Mac



Barry
01-18-2012, 03:18 PM
Hello,

I have been playing a game on my Mac (Quake), and it has been working fine.
I decided to download a newer version called QuakeTenebrae, and this also worked.
The only problem was that a message box popped up before I clicked 'play', and this message informed me that:

"Warning:
You are attempting to run TenebraeQuake on a system with an outdated OpenGL framework. You will experience display issues if you try to continue!

TenebraeQuake requires MacOS X v10.2.3 or later!"

This is confusing, as I am running OS X 10.5.8, which is obviously above 10.2.3.

I read on an OpenGL Mac information page that OpenGL is updated automatically every time there is an OS X system update.

These are my Mac specs:

OS X 10.5.8
Dual 2.3 GHz PowerPC G5
2GB DDR2 SDRAM

Graphics Card:
NVIDIA GeForce 6600

Can anyone help, as I have not received any replies from either the QuakeOne or Steam forums, (as yet).


BR.

Barry.

ZbuffeR
01-18-2012, 03:37 PM
I must admit I have not much experience with macs but indeed the version detection does not seem to work.

Can you be more precise about which version are you running ?
Because the original tenebrae is getting very old, not sure it is still updated.
This engine is still maintained however :
http://icculus.org/twilight/darkplaces/download.html

Barry
01-20-2012, 07:36 AM
Thanks for replying, ZbuffeR,

I have tried the most recent DarkPlaces build, and it worked first time!

Using the defaults was fine, even with full 1920 x 1080 resolution. The only time I noticed a difference is when I applied RT World shadows. Just applying RT world was OK.

I was thinking that I will have to upgrade to a newer Graphics card. Below is what I am currently using:

NVIDIA GeForce 6600
VRAM: 256

I was told my processor and RAM should be fine:

Dual 2.3 GHZ PPC G5
2 GB DDR2 SDRAM

Cheers!

Baz.