PDA

View Full Version : opengl problem



Anzar
12-31-2011, 04:36 AM
few days ago I purchased HP laptop Pavilion dv6-6166TX with ATI Radeon 6770m 1GB memory. Just after I started using it, I saw that there also Intel HD Graphics was lso there which supports opengl 3 while ATI card support opengl 4.1. Now I m unable to run opengl 4.1 based programs. I m also new opengl programmer and my testing programs shows opengl 3 not 4.1. I have checked it with GPU caps viewer it shows Intel HD not ATI while both are installed as Windows Device Manager list both.
Plz anyone can help me how can I use my ATI Card not intel card in my opengl programs.

Zyx_2000
12-31-2011, 08:22 AM
You might want to try updating the drivers for the ATI card. When I bought my HD 5770, the drivers included only supported OpenGL 2.1, but updating to the latest version made 4.1 available.

My guess would be that since the Intel card supports a higher OpenGL version, it is used instead.

Anzar
01-01-2012, 03:11 AM
Thnx for reply but I have already installed latest drivers from AMD and Catalyst shows latest drivers. When I ran GPU caps viewer it showed intel's HD graphics and not ATI Radeon:(.
Device manager also shows both are installed. What should I do more????

slahs
01-01-2012, 06:26 AM
try to change ATi card as primary adapter in your system bios.

Avithohol
04-30-2012, 02:27 PM
Hey, sorry to piggyback on this thread,
but i have to tell you that i was in the same sues as Anzar (http://www.opengl.org/discussion_boards/member.php/23097-Anzar)
and what Slahs mentioned has worked great.
Now iam on opengl 4.2 :)

Thank you