PDA

View Full Version : Need OpenGL 1.3 or higher



Jay Kanel
12-25-2011, 06:18 PM
Im playing Wakfu Online. This game need OpenGL 1.3 or higher for play.

I just installed a new Geforce 210 card (PCIexpress) in my PC. According to the box, it is supposed to support OpenGL 3. However, when I run GPU Caps Viewer under Windows, I see that only OpenGL 1.1.0 is supported (GDI Generic renderer). Almost all OpenGL applications fail to run. Direct3D seems to work fine (Grand Theft Auto runs fine. That wouldn't be the case without graphics acceleration). When I boot under Ubuntu, OpenGL works fine (the reported version is 3).

I already tried uninstalling/installing the graphics drivers a few times. I tried both the latest drivers from the NVidia site as the drivers that came with the card. I tried cleaning the registry. Nothing worked so far...

thokra
12-26-2011, 01:56 AM
What version of windows? Does your board have an integrated VGA? Which chip does GCV report?

Jay Kanel
12-26-2011, 02:07 AM
I use windows XP 32bit.
My board havent integrated VGA.
Chip: pentium 4 3.0ghz

thokra
12-26-2011, 03:14 PM
Are you absolutely sure the drivers are installd correctly?

Jay Kanel
12-27-2011, 11:13 AM
Im sure man =.=
When I boot under Ubuntu, OpenGL works fine. But window is not

mhagain
12-27-2011, 01:29 PM
That just means that your drivers aren't installed right. OpenGL has nothing to do with the OS - it's all in the drivers and hardware.

Jay Kanel
12-28-2011, 07:15 AM
How to fix that ?

V-man
12-28-2011, 10:24 AM
It is probably because of the registry. I'm not a Windows expert but there is a registry key called OpenGLDrivers (under Windows XP) which points to the actual GL driver supplied by the vendor. There may be other keys in the registry as well.

IMO, the best thing to do is reinstall Windows.

It could also be because you are not logged in as admin or perhaps a anti-virus that is causing the driver installer problems.