PDA

View Full Version : Makefile



shanshan
11-02-2011, 02:08 PM
I try to install software in my laptop
The head of the Makefile is:
INCDIR = /usr/X11R6/include
LIBDIR = /usr/X11R6/lib
GL_LIB = libGL.so
GLU_LIB = libGLU.so
GLUT_LIB = libglut.so

I cannot run this make file, and use command: # find / -name libGL.so
I can find nothing. Seems I need install something to get these files.
What I need do to get these lib files?
Thanks for any help you might be able to offer!
PS. I am using Fedora core 15. (fc15.i686)

Dark Photon
11-03-2011, 02:28 PM
Install the OpenGL driver from your vendor (or Mesa as a fallback).

In the old days, this kind of thing would be in /usr/X11R6/lib.

However, nowadays they're down in /usr/lib (32-bit) or /usr/lib64 (64-bit).

Run this:
ls -l /usr/lib*/libGL.*

shanshan
11-04-2011, 11:11 AM
Thank you Dark Photon .
I use the command:
# ls -l /usr/lib/libGL
libGL.so.1 libGL.so.1.2 libGLU.so.1 libGLU.so.1.3.070801
so I did not have the lib file libGL.so & libGLU.so
is there any relationship between libGL.so, libGLU.so and libGL.so.* , libGLU.so.*?

and use command:
# find / -name ‘libglut.so’
I can find nothing, is that mean I need install something else?

Dark Photon
11-04-2011, 12:50 PM
Thank you Dark Photon .
I use the command:
# ls -l /usr/lib/libGL
libGL.so.1 libGL.so.1.2 libGLU.so.1 libGLU.so.1.3.070801
so I did not have the lib file libGL.so & libGLU.so
is there any relationship between libGL.so, libGLU.so and libGL.so.* , libGLU.so.*?
Usually what this means is that you have the GL library package installed but you also need to install the GL devel package. They seem to put the library .so symlinks in the devel package. For instance, here I have:



$ rpm -qa | grep -i mesa | sort | uniq
mesa-libGL-6.5.1-7.8.el5
mesa-libGL-devel-6.5.1-7.8.el5
mesa-libGLU-6.5.1-7.8.el5
mesa-libGLU-devel-6.5.1-7.8.el5



and use command:
# find / -name ‘libglut.so’
I can find nothing, is that mean I need install something else?

So looks like you need to install GLUT lib and devel packages. For instance, here:



$ rpm -qa | grep -i glut | sort | uniq
freeglut-2.6.0-1
freeglut-devel-2.6.0-1

shanshan
11-08-2011, 09:41 AM
Thank you so much.
I just install all of these packages you list, and now it works.