PDA

View Full Version : GPU supports v4.1 but not 1.3?



trakof
10-03-2011, 08:57 PM
I have a Radeon HD 5770 gpu which supports version 4.1 of GLSL which works fine when running a shader written with that version. However I cannot use a shader of version 1.3 (1.2 also works fine, haven't been able to test others). Is this normal or could it maybe be a problem with my graphics card?

Alfonse Reinheart
10-03-2011, 09:20 PM
It is technically possible that a 4.1 implementation would be unable to support GLSL shader version 1.30. It isn't required. However, it would be highly unlikely to not support 1.30 while simultaneously supporting 1.20.

It's more likely that you did something wrong in your shader.

trakof
10-03-2011, 09:33 PM
This is the shader I'm trying to use

#version 130

precision highp float;


uniform sampler2D texture0;

in vec2 texCoord0;

out vec4 outColor;

void main(void) {
outColor = texture(texture0, texCoord0.st);
}

It works fine on other computers using that exact shader and in the same program :confused: .

Alfonse Reinheart
10-03-2011, 10:16 PM
What error do you get when you compile it?

trakof
10-03-2011, 10:34 PM
It just says "failed to compile with the following errors:"
but doesn't give any errors.