PDA

View Full Version : How to configure OpenGL acceleration in Win2K?



Dimension
09-27-2011, 01:06 AM
Help! How do I configure OpenGL acceleration in Win2K?
A program is telling me I need to set my openGL to Hardware- it's apparently on Software now...
can't find anything on openGL in DXDiag...not sure how to configure it...
I can't use that OpenGL Viewer program mentioned in the minecraft thread...it requires XP & I'm not running that yet(yeah, I know, don't tell me...)
Anyway, for now, until I get a new video card & upgrade to XP, can you tell me how to get it done?

My current video card is a AsusA9250 with graphics by ATI Radeon9250...AGP 8X, 128M DDR, & yes, it DOES offer OpenGL support, says right on the box... (despite the fact that I still have the box, I HAVE Had it a While...)

Anyway, any assistance you could offer would be greatly appreciated!! Thank you!!

mhagain
09-27-2011, 01:59 AM
Download and install the most up to date drivers for it and you will have OpenGL support. If that doesn't do it then your hardware is not up to spec.

Aleksandar
09-27-2011, 04:27 AM
Radeon 9250 (R200) should be OpenGL 1.4 compliant. That was the first of ATI's chips that supports programmable pixel shaders. If you need something with the shaders you really need a hardware upgrade.

Dimension
09-27-2011, 10:19 PM
I went to http://support.asus.com/Download.aspx?SLanguage=en&m=A9250+Series&p=9&os= to download the drivers for it, 121-178MB!! :eek: :sorrow: :eek: [/B] There's no WAY I can download anything that huge with my SLoooWW Dialup connection!! Anybody want to download it with their hi-speed connection & send me a CD? :D

Actually, I know my card has shaders...(per the datasheet, the Radeon9250 has a 4-pixel shader pipeline architecture & SmartShader™), that's why I bought it... my Driver3 required a card with shaders, and my onboard Intel video didn't have them, so I bought the ATI... I think I just need to find a way to change the acceleration for OpenGL to Hardware...

aqnuep
09-28-2011, 12:12 AM
The only shaders the Radeon 9250 supports is vertex shader and ATI's proprietary extension for fragment shading ATI_fragment_shader, however, it does not support GLSL.

This is not a matter of "acceleration for OpenGL to hardware", it is simply lack of hardware support. You need at least a Radeon 9500+ to have GLSL based fragment shading but that's a very old card as well and has also many hardware limitations.

mhagain
09-28-2011, 02:09 AM
There is also no magic toggle that will switch OpenGL to hardware. It's either hardware accelerated by the driver or it's not, and if it's not then there is nothing that can be done. Because what the hardware can or cannot do is god, king and master of all it surveys.

V-man
09-28-2011, 07:02 AM
Go to ati.com and download their 11 MB driver. You don't need to download the catalyst suit driver, which is 34 MB.

Dimension
09-30-2011, 03:24 AM
Thanks V-Man...don't suppose you might have a tip how I could find that driver...?

Dimension
10-06-2011, 05:42 PM
Thanks V-Man...don't suppose you might have a tip how I could find that driver...?

C'mon, really, maybe I'm stupid, but I'm having a hard time finding that driver...how about helping me out with a link?
Would really appreciate it...thanks! :)

V-man
10-08-2011, 08:54 AM
Go to ati.com or amd.com
At the top it says Support & Drivers.
Then select your card, OS, etc.