PDA

View Full Version : Just started OpenGL, having massive problems-



leninovich
07-23-2011, 04:07 PM
Hey guys, I'm new to the forum (and OpenGL in general) and I've been having a bit of a major problem compiling a program. I recently acquired the OpenGL Superbible 4th Edition, and upon compiling the first program, it says "libc.lib" not found while linking. From what I've read, its because the included freeglut_static.lib isn't compiled multithreaded, so it doesn't work. I'm having trouble finding a freeglut_static.lib file that is multithreaded so could someone help me? I need either a precompiled freeglut_static.lib file that would work, or instructions on what to do to fix this file. Thanks in advance!

mobeen
07-23-2011, 09:13 PM
just download freeglut and build the library on your machine as u wish.

leninovich
07-23-2011, 11:05 PM
I'm not sure which version the openGL superbible 4th edition uses, and if it matters. I'm also not too good at building libraries myself, so I don't really know how to make a static library of freeglut. I was hoping someone had the freeglut_static.lib file that was multithreaded, it was uploaded somewhere but the page doesn't work anymore.

leninovich
07-24-2011, 12:15 PM
Can someone please help me, at least tell me how to compile the multi-threaded version of freeglut_static.lib? I tried it myself and got the same error. Or can someone upload the compiled version for me?

mobeen
07-24-2011, 09:43 PM
I tried it myself and got the same error.

Could u share with us the errors that u get during compilation?

A.Conz
07-25-2011, 12:18 AM
(under windows, vs)project properties ->linker -> input -> ignore specific libraries -> insert "libc.lib"