PDA

View Full Version : gl_ViewportIndex unknown on GTX 580



jkl
11-20-2010, 04:56 PM
Did myself a treat and bought GTX 580, and now I get a link error:

Geometry info
-------------
error: unknown builtin varying parameter (named gl_ViewportIndex) encountered

along the usual hick ups I got on GTX 480.
My shaders start with:

#version 410
#extension GL_ARB_viewport_array : enable

so in theory there should be no problem with this output variable. If any of the NVIDIA driver writers reads this forum: HELP,...!

Edit:
Somehow got it working on FW263.06.

Alfonse Reinheart
11-20-2010, 07:39 PM
#extension GL_ARB_viewport_array : enable

FYI: Viewport arrays are core in 4.1. So you don't need to enable the extension; just having the 410 version specifier is sufficient.

Chris Lux
11-21-2010, 12:29 AM
NV driver bug. the driver versions 260.93, 262.99 and 261.00 (and surely beyond that versions) have this fixed at my side.

-chris

jkl
11-21-2010, 05:33 PM
Thanks Alfonse, that's so pro I must have missed it when I have last read the spec... or maybe I've forgot it already -- I read it last time like yesterday ;). Or maybe I tied to solve this in a similar way as the bug with missing coherent keyword, that I fixed by adding #extension GL_NV_gpu_shader5 : enable. And I am pretty sure that coherent is part of GL_EXT_shader_image_load_store.

I am pretty sure that it doesn't work with 262.99 Chris -- that was the first driver that I have tried with GTX 580.

Sorry for being so harsh guys, but I get really frustrated with this bugs.

Chris Lux
11-22-2010, 03:09 AM
Jep, the version numbers on nvidia drivers sadly almost never means something in regard to the OpenGL implementation they offer. So the 262.xx seems to come from another driver branch than the devel beta drivers (260.93, 261.00). I must have mistaken the 262.xx driver to support it. The other two definitely support it, but they do not support the GTX 580. :p