PDA

View Full Version : anyone else experience crashing with latest nvidia



rwblodgett
11-05-2010, 02:27 PM
Is anybody else experiencing hard crashes with nvidia opengl drivers lately? Seems we got hit by a bunch recently.

These drivers are having problems for us:

Machine 1:
Microsoft Windows 7 Professional
NVIDIA GeForce 9600 GT
crashes: 8.17.12.5896
crashes: 8.17.12.6099 - latest
no crashes: 8.17.11.9745 - older - this one is good.

Machine 2:
Microsoft Windows XP Professional
NVIDIA GeForce GTX 260
crashes: 6.14.12.5896

Machine 3:
OS Name Microsoft Windows 7 Professional
NVIDIA Quadro FX 3800M
crashes: 8.16.11.8918
no crashes: 8.17.12.6099 - latest - this one is good

YarUnderoaker
11-05-2010, 04:04 PM
I have crashing after glProgramBinary fail with message "binary data corrupted" when executing glDeleteObject or glLinkProgram (creating shader as usual).
Binaries just loaded from file and can't be corrupted.

Driver 8.17.12.6099 NVIDIA GeForce GTX 260 Win7 Ultimate

Alfonse Reinheart
11-05-2010, 05:05 PM
Were they loaded from a file that was written under that driver version?

YarUnderoaker
11-06-2010, 10:40 AM
Were they loaded from a file that was written under that driver version?
May it be, because I trying to find stabe driver and change them.
I'm working on node base shader graph editor where often doing detaching, attaching, linking and binary storing. On last point, I probably got a little heated, so leaving it only for run time.

YarUnderoaker
11-07-2010, 10:38 AM
Also I have driver fail when detaching shaders from program
then again attaching. In next DIP after that I got Access Violation in nvogl32.dll. No any OpenGL error or memory corruption and testing on ATI driver - there not such problem.

In my application I have one PBuffer context in subthread, one backward context, two forward context based on different windows. All context have debug flag and shared with first context during creation. Thet all work on old driver (I not sure, seemingly 259.09).