PDA

View Full Version : Opengl only using software acceleration - HELP!



openglisdrivingmenuts
09-25-2010, 01:17 PM
The situation: I used to have Windows Vista, recently upgrade to Windows 7 (64 bit). I have a NVIDIA Geforce 9600 gt video card.

Direct x works perfectly fine with it. Open GL refuses to run using the cards hardware accelerator.

Example: I'll run Lightwave (which is strictly open gl) and all the graphics are being run using the software. It doesn't matter how much I tweak the open gl settings in RivaTuner, my graphics card isn't touching the Opengl graphics to make a change, Period.

To completely hammer home that it's only rendering using software I went into my system32 and removed the NVIDIA graphics dll (nvoglv64.dll) and loaded up lightwave again - and it worked exactly the same way as when the file was there, proving that it's not accessing my video card at all. I've also tried several games, and they all run slow as garbage because the open gl can't seem to access the card, so it does "software rendering only mode."

I've installed the latest drivers, I even went back to my installation disc that came with the card and used the original driver as a test. I even went back and used the graphics card that the computer CAME WITH and it won't even use Open GL on that - I have confirmed it's not a problem with the cards or the drivers - but windows not being able to access the video cards open gl function for some reason

I've spent the past 10 hours googling and trying to find an answer. I'm going crazy with this. When I had Vista everything worked perfectly fine.

mhagain
09-26-2010, 10:29 AM
You're either using the generic MS-provided driver or a crippled OEM driver, but definitely not an NVIDIA driver. OpenGL works great on Windows 7 x64 and full hardware acceleration is supported, so download the correct driver from the NVIDIA website and use that.

openglisdrivingmenuts
09-26-2010, 03:27 PM
Update - I have discovered that the graphics card IS accelerating open gl. If I go into nvidia control panel and adjust the image settings they take affect

BUT - it's running at 1/10th at least the speed. Whereas Direct X is running at full speed. Making it impossible to run anything that needs Open GL

I have all the recent drivers from the website. I've tried older drivers, newer drivers - it doesn't matter what driver I use OPENGL refuses to run at full speed since I changed my copy of windows.

If I didn't shave my head I'd be pulling my hair out right now.

openglisdrivingmenuts
09-26-2010, 06:59 PM
Never mind, fixed the issue - if anyone else happens to stumble onto this problem what you have to do is make sure direct x is updated to its latest drivers. What updating direct X and open GL have in common I have no idea.