PDA

View Full Version : ATI Mobility Radeon problems



Melanikus
05-23-2010, 10:42 PM
So, I'm making this opensource didactic examples to help a teacher to show CG tecniques with interactive examples. Two of them are related to cube-mapping and another one has a phong shader. I'm having problems.

I've made the samples on my desktop with a NVidia 9800 GTX+ and tried them on my laptop which is a HP DV-4 with a HD 4200 Mobility Radeon card, two problems arised, first, texture border does not work on the HD4200, no erros, just freezes, also, when I'm using shaders, I get a error linking the shaders, if I ignore it, the shader still runs perfectly even tho GL_LINK_STATUS returns 0 (both problems do not happen on my desktop). Also, no infolog is returned after I link the shaders

I can live with both problems but I want to make it right, first, is there any way to check if texture border is availible? as far as I know there's not texture border extension (to be checked) and it should be part of usual OpenGL implementation (1.3 if I'm not mistaken)

I've looked alot for a way to check, updated drivers and still got nothing. Any ideas? Thanks alot!

Melanikus
05-28-2010, 01:16 AM
Sorry guys, I was checking shader compile status with glGetShaderiv instead of glGetProgramiv =/

Also,guys in AMD developer foruns told me that pixel border is not hardware supported by ATI. So, it's solved! I would like to know if there's a way in the OpenGL API to check for the OpenGL driver manufacturer or something like that, I wanna port to Linux and Mac and I don't want to make any system or specific lib calls, I am using GLEW tho, any ideas?

Thanks for all people who took time reading it!

Melanikus
05-28-2010, 09:43 AM
Guys in AMD developer helped, glGetString(GL_VENDOR) is the answer, thanks alot everyone!