PDA

View Full Version : GLW_StartOpenGL() - could not load OpenGL subsyste



mattes
02-08-2010, 07:51 AM
Hi all,

at first: sorry for my english its not so good ;)

Now my problem:
When i want to play the game
Wolfenstein Enemy Territory (http://en.wikipedia.org/wiki/Wolfenstein:_Enemy_Territory) it doesent starts.
The console opens and says: GLW_StartOpenGL() - could not load OpenGL subsystem.
Yesterday i got new hardware:
Radeon HD 5770
and i installed thss driver:
10-1_xp32_dd_ccc_wdm_enu (http://game.amd.com/us-en/drivers_catalyst.aspx?p=xp/radeonx-xp)
Do you know the problem or do you know how to solve it ?

Thank you
Mattes

ZbuffeR
02-09-2010, 03:53 AM
Sound ok, can you post the complete log in the W:ET console ?

mattes
02-09-2010, 05:11 AM
here it is:

ET 2.55 win-x86 May 27 2003
----- FS_Startup -----
Current search path:
C:\PROGRA~1\WOLFEN~1\etmain\~.pk3 (84 files)
C:\PROGRA~1\WOLFEN~1\etmain\zz_disable_default_cam paigns.pk3 (3 files)
C:\PROGRA~1\WOLFEN~1\etmain\zz_disable_default_cam paigns.c6f640b7.pk3 (3 files)
C:\PROGRA~1\WOLFEN~1\etmain\venice.pk3 (330 files)
C:\PROGRA~1\WOLFEN~1\etmain\UJE_space_panzer.pk3 (67 files)
C:\PROGRA~1\WOLFEN~1\etmain\UJE_room_panzer_b3.pk3 (95 files)
C:\PROGRA~1\WOLFEN~1\etmain\UJE_lava_panzer_b1.pk3 (48 files)
C:\PROGRA~1\WOLFEN~1\etmain\UJE_jungle_panzer_b1.p k3 (69 files)
C:\PROGRA~1\WOLFEN~1\etmain\UJE_ghetto_panzer_b1.p k3 (175 files)
C:\PROGRA~1\WOLFEN~1\etmain\UJE_forest_panzer_b1.p k3 (70 files)
C:\PROGRA~1\WOLFEN~1\etmain\UJE_egypt_panzer.pk3 (125 files)
C:\PROGRA~1\WOLFEN~1\etmain\UJE_cartoon_panzer.pk3 (251 files)
C:\PROGRA~1\WOLFEN~1\etmain\UJE_camping_sniper_b3. pk3 (191 files)
C:\PROGRA~1\WOLFEN~1\etmain\UJE_bathroom_panzer_b1 .pk3 (232 files)
C:\PROGRA~1\WOLFEN~1\etmain\TWC_pizza_delivery.pk3 (103 files)
C:\PROGRA~1\WOLFEN~1\etmain\tutorialjump.pk3 (50 files)
C:\PROGRA~1\WOLFEN~1\etmain\supplydepot2.pk3 (46 files)
C:\PROGRA~1\WOLFEN~1\etmain\SuperGoldrush_Final.pk 3 (170 files)
C:\PROGRA~1\WOLFEN~1\etmain\Stonehenge_KOTH_nocmp. pk3 (48 files)
C:\PROGRA~1\WOLFEN~1\etmain\sniperion_b1.pk3 (18 files)
C:\PROGRA~1\WOLFEN~1\etmain\snatch3.pk3 (34 files)
C:\PROGRA~1\WOLFEN~1\etmain\school.pk3 (115 files)
C:\PROGRA~1\WOLFEN~1\etmain\rage3.pk3 (31 files)
C:\PROGRA~1\WOLFEN~1\etmain\purefrag_final.pk3 (30 files)
C:\PROGRA~1\WOLFEN~1\etmain\purefrag.pk3 (21 files)
C:\PROGRA~1\WOLFEN~1\etmain\purefrag.cc3c7ace.pk3 (21 files)
C:\PROGRA~1\WOLFEN~1\etmain\pong_v3.pk3 (44 files)
C:\PROGRA~1\WOLFEN~1\etmain\pong_v3.6ef32447.pk3 (44 files)
C:\PROGRA~1\WOLFEN~1\etmain\panzerarena.pk3 (10 files)
C:\PROGRA~1\WOLFEN~1\etmain\pak0.pk3 (3725 files)
C:\PROGRA~1\WOLFEN~1\etmain\mp_bin.pk3 (4 files)
C:\PROGRA~1\WOLFEN~1\etmain\gamma_mill_b2.pk3 (384 files)
C:\PROGRA~1\WOLFEN~1\etmain\gammaland_b2.pk3 (47 files)
C:\PROGRA~1\WOLFEN~1\etmain\Frostbite.pk3 (99 files)
C:\PROGRA~1\WOLFEN~1\etmain\flag_in_the_middle.pk3 (68 files)
C:\PROGRA~1\WOLFEN~1\etmain\ctf-face-fp1_fixed.pk3 (80 files)
C:\PROGRA~1\WOLFEN~1\etmain\cortex.pk3 (359 files)
C:\PROGRA~1\WOLFEN~1\etmain\baserace_desert.pk3 (154 files)
C:\PROGRA~1\WOLFEN~1\etmain\baserace.pk3 (129 files)
C:\PROGRA~1\WOLFEN~1\etmain\adlernest.pk3 (113 files)
C:\PROGRA~1\WOLFEN~1/etmain

----------------------
7690 files in pk3 files
WARNING: profile.pid found for profile 'Stalker' - system settings will revert to defaults
execing default.cfg
couldn't exec language.cfg
execing profiles/Stalker/etconfig.cfg
r_smp is unsafe. Check com_crashed.
r_mode is unsafe. Check com_crashed.
r_depthbits is unsafe. Check com_crashed.
r_stencilbits is unsafe. Check com_crashed.
r_stereo is unsafe. Check com_crashed.
r_colorbits is unsafe. Check com_crashed.
r_texturebits is unsafe. Check com_crashed.
r_clampToEdge is unsafe. Check com_crashed.
r_ext_texture_env_add is unsafe. Check com_crashed.
r_nv_fogdist_mode is unsafe. Check com_crashed.
r_ext_NV_fog_dist is unsafe. Check com_crashed.
r_ext_texture_filter_anisotropic is unsafe. Check com_crashed.
r_ati_fsaa_samples is unsafe. Check com_crashed.
r_ati_truform_pointmode is unsafe. Check com_crashed.
r_ati_truform_normalmode is unsafe. Check com_crashed.
r_ati_truform_tess is unsafe. Check com_crashed.
r_ext_ATI_pntriangles is unsafe. Check com_crashed.
r_glIgnoreWicked3D is unsafe. Check com_crashed.
r_ext_compiled_vertex_array is unsafe. Check com_crashed.
r_ext_multitexture is unsafe. Check com_crashed.
r_ext_gamma_control is unsafe. Check com_crashed.
r_ext_compressed_textures is unsafe. Check com_crashed.
r_allowExtensions is unsafe. Check com_crashed.
r_glDriver is unsafe. Check com_crashed.
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
...detecting CPU, found AMD w/ 3DNow!
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\system32\opengl32.dll' ): succeeded
...setting mode 4: 800 600 FS
...using desktop display depth of 32
...calling CDS: ok
...registered window class
...created window@0,0 (800x600)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 32, 24, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (4)
...setting mode 4: 800 600 FS
...using colorsbits of 16
...calling CDS: ok
...created window@0,0 (800x600)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
...assuming '3dfxvgl' is a standalone driver
...initializing QGL
...WARNING: missing Glide installation, assuming no 3Dfx available
...shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
GLW_StartOpenGL() - could not load OpenGL subsystem

ZbuffeR
02-09-2010, 05:40 AM
Usually this log only happens when no accelerated OpenGL was found (ie. no appropriate video driver).

Try downloading and running glview, to check for supported GL version and vendor :
http://www.realtech-vr.com/glview/download.html

mattes
02-09-2010, 06:45 AM
I have openGL 1.1 and the vendor is Microsoft corporation

ZbuffeR
02-09-2010, 06:57 AM
What I said.
So it sound something went wrong during driver installation, you should deinstall it as well as previous ones (such as for your previous card), then try it again :
- install as administrator
- disable antimalware during install
- check graphic acceleration slider is to the max
...

What was your previous card ?

mattes
02-09-2010, 07:02 AM
Radeon X800

mattes
02-09-2010, 08:09 AM
it doesnt help :(

Ysaneya
02-11-2010, 08:10 AM
Did you check if you have video acceleration enabled in the windows settings ? There's a tab for it somewhere if I remember well. If it's set to lower than full acceleration, OpenGL will fall back to the software drive, even if a proper driver was installed.

mattes
02-11-2010, 01:42 PM
nothing happens... =(

V-man
02-16-2010, 10:59 AM
It is probably because the installer is not able to modify the registry settings or something is wrong with the registry. You may have to reinstall windows.

mattes
02-17-2010, 05:54 AM
I'm going to buy Windows 7 =)
I just need the money...