PDA

View Full Version : Another GDI Generic Problem--But Different



Caglow
01-30-2010, 06:52 PM
OpenGL Extension Viewer under the normal power user account says I have "GDI Generic" as my default renderer (and of course, that means OpenGL 1.1). I got the program in the first place after experiencing some extremely slow FPS on OpenGL applications I'm trying to learn from like Stellarium but that becomes VERY hard with 0.06 FPS.

So here's how this case is different: the problem ONLY occurs for this account. On an account with administrative rights, OpenGL works fine (updated to 1.4). Even weirder, OpenGL still works fine if I go into the administrator account and do "Run as" and run the program as a non-admin and vice-versa. This rules out a problem with the drivers.

I read somewhere that there are registry entries you need to have in order to have OpenGL running properly. Since the problem only occurs when logged into the power user account, I would assume that the problem has to be in HKCU or possibly HKUS (since doing Run as doesn't kill the problem; you have to switch users to make it work). Someone said on a different site that this site has a list of those registry entries that are needed but I can't find them.

System Information:
Video card: Intel 915G (drivers updated to OpenGL 1.4; latest possible)
Operating System: Windows XP Professional SP3 (Genuine)
Processor: Intel Pentium 4 Duo-Core 2.8GHz

Caglow
01-30-2010, 07:05 PM
Some more information:

Ever since 2-3 weeks ago when my computer completely froze up and I had to force off the computer, the account has been loading up very slowly. Also, several applications don't seem to be working because of syntax errors (they used .NET, not OpenGL so they have lower priority). It could be a result of me messing with the registry somehow (I might have had regedit open at the time) but the computer freezing happened when I was browsing through a removable disk (which I had been doing for about 2 minutes). I think it happened after I opened a .NET app so that might have done something which needed some deleted registry entries. It's not a virus--I have the source code to it, had to build it from source and have used it before without problems (I think it was a syntax highlighting textbox).

The above is probably unneeded for answering my question but is some background information on how this all happened.

V-man
02-02-2010, 08:21 AM
I think the registry settings are for all users. If it works for some users but not for admin, then it is probably because you have acceleration turned off.
Open the control panel.
Click on display.
click on settings.
at the bottom, click on advanced button.
click on Troubleshoot
make sure that slider is at FULL hardware acceleration.
there is also the enable write combining which normally is checked.

Caglow
02-03-2010, 07:22 PM
Thanks for the reply. I won't have access to that computer until the end of the week but I'll make good use of your suggestion. I'll report back when I get to it.

Caglow
02-06-2010, 11:48 AM
Darn, it didn't work. The slider was already at the far right (and greyed out) and the checkbox was also checked. (and also greyed out) Any other suggestions?

Brolingstanz
02-06-2010, 01:39 PM
If you hosed your registry tinkering with things you may need to reinstall your OS.

Caglow
02-07-2010, 05:06 PM
Reinstalling the OS is the LAST thing I would do. Considering the problem only affects 1 user. Well, ALL the problems only affect 1 user. I'm thinking this is the wrong place to post the problem since the majority of problems involve .NET but I figure you guys might know a thing or two about what might break OpenGL (and the fact that I have no idea what exactly the problems with .NET are). I'll post on other forums and come back with an answer if I find one. And I'm going to downgrade this account to a Limited User...

Caglow
02-08-2010, 02:42 PM
PROBLEM SOLVED! It was my firewall. COMODO has this really great program called Defense++ which blocks viruses from accessing the registry and stuff. It also blocked all non-trusted applications from accessing my OpenGL driver. I guess the firewall stores per-user settings as well.