PDA

View Full Version : GL 3.2 and pre GL 3.2 code base



Mars_999
01-25-2010, 05:34 PM
Will my old code from e.g. immediate mode work with a GL 3.2 RC?
I have some older libs that are probably using immediate mode to render GUI widgets, and fonts... I am guessing that they may work now, but may not in the future due to that support can be dropped at anytime?

Thanks

Dark Photon
01-25-2010, 06:02 PM
Will my old code from e.g. immediate mode work with a GL 3.2 RC?
If you allocate a context with the compatibility profile enabled.

Iulian B
01-26-2010, 06:02 AM
well, now when you init OpenGl in the "pre 3.0 way", you get an 3.2 context with the GL_ARB_compatibility in it, so it's basically like pre- 3.0 gl with all the added goodies up untill 3.2.

But, remember, the imediate mode is now an EXTENSION that is not required for the core 3.2 specifications, so just treat it like any extension.
That means 2 things: 1) At initialisation time, check if that extension is supported or not and 2) If you detect that it is not supported you have to choose to either not run the application or to provide some fallback mechanism (wow, now we got to the point when you have to provide shader fallbacks for fixed function :D ).