PDA

View Full Version : Windows7 32bit cant find openGL



bryn thornley
12-02-2009, 05:21 PM
I have vista Toshiba satellite L500 that played a game with openGL or something to do with it. It worked then I upgraded to windows7 32bit and the game dosn't work any more. The game is called tremulous. If you need any mroe info just say how to get it. This is what the command console says when I try to play the game:
(flashing in red up top"GLW_StartOpenGL() - could not load OpenGL subsystem")
tremulous 1.1.0 win_mingw-x86 Feb 17 2007
----- FS_Startup -----
Current search path:
C:\Users\bryn\AppData\Local\Tremulous/base
C:\Users\bryn\Desktop\Tremulous\base\vms-1.1.0.pk3 (4 files)
C:\Users\bryn\Desktop\Tremulous\base\map-UTCSfinal.pk3 (82 files)
C:\Users\bryn\Desktop\Tremulous\base\map-uncreation-1.1.0.pk3 (110 files)
C:\Users\bryn\Desktop\Tremulous\base\map-tremor-1.1.0.pk3 (45 files)
C:\Users\bryn\Desktop\Tremulous\base\map-transit-1.1.0.pk3 (135 files)
C:\Users\bryn\Desktop\Tremulous\base\map-niveus-1.1.0.pk3 (134 files)
C:\Users\bryn\Desktop\Tremulous\base\map-nexus6-1.1.0.pk3 (151 files)
C:\Users\bryn\Desktop\Tremulous\base\map-karith-1.1.0.pk3 (118 files)
C:\Users\bryn\Desktop\Tremulous\base\map-darkcastle.pk3 (57 files)
C:\Users\bryn\Desktop\Tremulous\base\map-atcs-1.1.0.pk3 (87 files)
C:\Users\bryn\Desktop\Tremulous\base\map-arachnid2-1.1.0.pk3 (67 files)
C:\Users\bryn\Desktop\Tremulous\base\data-1.1.0.pk3 (1229 files)
C:\Users\bryn\Desktop\Tremulous/base

----------------------
2219 files in pk3 files
execing default.cfg
execing autogen.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
...detecting CPU, found generic

------- Input Initialization -------
No window for DirectInput mouse init, delaying
Joystick is not active.
------------------------------------
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\Windows\system32\opengl32.dll' ): succeeded
...setting mode 3: 640 480 *
...using desktop display depth of 32
...calling CDS: ok
...registered window class
Alt-Tab support disabled (win_allowAltTab = 0)
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 8 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 32, 24, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...setting mode 3: 640 480 FS
...using colorsbits of 16
...calling CDS: ok
Alt-Tab support disabled (win_allowAltTab = 0)
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
...assuming '3dfxvgl' is a standalone driver
...initializing QGL
...WARNING: missing Glide installation, assuming no 3Dfx available
...shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
GLW_StartOpenGL() - could not load OpenGL subsystem

Brolingstanz
12-02-2009, 07:30 PM
GLW_ChoosePFD weirdness.

You can search this forum for reams of generic troubleshooting tips but offhand you might try cleanly reinstalling the very latest video drivers from your vendor's website.