PDA

View Full Version : help needed to install GLU 1.3 on Windows XP



urhere
09-11-2009, 09:24 AM
First, I beg forgiveness if this has been discussed before, or worse, if it's in a FAQ. I did find an earlier thread here:
old thread (http://www.opengl.org/discussion_boards/ubbthreads.php?ubb=showflat&Number=216826&Searchpa ge=4&Main=43206&Words=glu+1.3+install&Search=true# Post216826)
I am currrently using Visual Studio 2005 on Windows XP, writing a C++, MFC-based application that has been successfully using GLU 1.2. I now need to move to GLU 1.3 to get access to the NURBS tessellator callbacks. I have downloaded glu.h, glu32.dll, and glu32.lib from vmelkon (http://www.geocities.com/vmelkon/glu.html) and installed glu.h and glu32.lib in C:\Program Files\Microsoft Visual Studio 8\VC\PlatformSDK\Include and \Lib respectively. I'm not sure what to do with glu32.dll, given that Windows won't let me replace it (it overwrites it) in the SYSTEM32 directory. I have tried putting the new glu32.dll in various places (in multiple folders within the project path) and have placed it in SYSTEM32 with the alternate name glu32_1.30.dll as suggested in vmelkon's installation instructions.

I'm testing the installation using the surfpoints.c sample code from the Red Book. I can build the project successfully, and since all the nurbs callback defines are now recognized, I know that the new glu.h must have been included correctly (they were not recognized before). However, when I run the program through the debugger, it exits as soon as it executes the first line in the code that references one of the new callback enumerations. This suggests to me that either the new glu32.lib or glu32.dll hasn't been installed correctly. I'm betting it's the DLL.

I've been away from the MS compiler world for awhile and I'm pretty rusty with project construction and linking. Can anyone let me know what I've done wrong here? Thanks very much.

Jim

urhere
09-11-2009, 09:59 AM
Ok--Im an idiot. The only place I didn't try locating glu32.dll was the most obvious place: the project's debug directory. In any case, if this happens to you, put your copy of glu32.dll in the location below:

TopLevelProjectFolder
debug <------------put glu32.dll here
ProjectSrcFolder
__Debug <--------don't put it here!

Thanks for taking a look.

Jim