PDA

View Full Version : Help Please



BrandoLyton
07-07-2009, 09:47 AM
Hey guys. I am new to the forum and to OpenGl. I have been learning C++ for maybe a month now. But i need help.

When ever i try to debug my OpenGl i get this error:
1>Linking...
1>LINK : fatal error LNK1181: cannot open input file 'kernel32.lib'

i have glut\lib,windows sdks\lib, and OGLSDK\lib in my directories I have been messing around with settings for about an hour or two now and nothing will work. So i thought i would come to the professionals.

Thanks for any help,
Brandon

ajedwards888
07-08-2009, 03:53 AM
Are you sure the file exists? The kernel32.lib file should be here 'C:\Program Files\Microsoft SDKs\Windows\v6.0A\Lib'. First check that this exists. If it doesn't you need to install the latest version of the microsoft SDKs.

If that doesn't work try adding 'C:\Program Files\Microsoft SDKs\Windows\v6.0A\Lib' to your directories, see what happens!

Worth a try.

ajedwards888
07-08-2009, 03:55 AM
If this doesn't work, then go to the properties of the project you're trying to build and into 'Linker' then 'Input'. Click on the 3 dots that appear when you hover over the 'Additional Dependencies'. Is 'Inherit from parent or project defaults' ticked? It probably should be. And you should see kernel32.lib under the list of 'inherited values'.

good luck.

BrandoLyton
07-08-2009, 10:02 AM
Now i get an serror saying it can't find the c:\windows.obj

Btw all my stuff is in c:\ not my program files

Brolingstanz
07-09-2009, 02:01 AM
Hehe.... which IDE are you using?

BrandoLyton
07-09-2009, 10:55 AM
Visual C++
Are there even any others? XD

Brolingstanz
07-09-2009, 11:17 AM
NetBeans is a nice IDE.

Anyways, the default settings should be up to snuff for a basic app build in VS, so unless you've changed something....

BrandoLyton
07-09-2009, 01:37 PM
I will try netbeans. Thanks :) I will reply here with update if it works :)

ajedwards888
07-15-2009, 02:30 AM
the c:\windows.obj error is due to the linker section of your project settings. look in General/Additional library directories and Input/Additional directories. The error occurs if you have included something without quotes, e.g. c:\windows ce\tools, and it chops off everything after the space and adds '.obj' to the end. all you need to do is put it in quotes, i.e. "c:\windows ce\tools". this should solve the problem. if you can't find something that would cause this, have a look in other places that might cause a similar problem. let us know if it works!