PDA

View Full Version : Question/Problem with openGL/driver



NielsV
05-27-2009, 01:56 AM
I have:
ATI Mobility Radeon X1600.
Latest driver for this card.
A lower version of openGL than 1.2

I need:
OpenGL version 1.2 or higher

Problem:
ATI doesn't update the radeon X1600 drivers anymore.

What do I do?

Thanks!
Niels.

Nighthawk
05-27-2009, 02:45 AM
http://support.amd.com/us/gpudownload/Pages/index.aspx

Select your OS, the Mobility X1600 and you should get the Catalyst 9.3 driver. (AFAIK, ati will only release a new driver every 3 month for "legacy" hardware).

Heiko
05-27-2009, 02:57 AM
I have:
ATI Mobility Radeon X1600.
Latest driver for this card.
A lower version of openGL than 1.2

I need:
OpenGL version 1.2 or higher

Problem:
ATI doesn't update the radeon X1600 drivers anymore.

What do I do?

Thanks!
Niels.

If you have the latest drivers for your graphics card (which are 9.3 as reported above), you should have OpenGL 2.1 already. How are you checking the OpenGL version? Are you creating your own OpenGL application? In that case use a library like glew to get access to all functions.

Check also this topic:
http://www.opengl.org/discussion_boards/ubbthreads.php?ubb=showflat&Number=257541#Post257541