PDA

View Full Version : No hardware acceleration on Win2k with Intel 945GM



Gullible Jones
05-23-2009, 09:04 PM
Hi... I'm trying to play several OpenGL games on Windows 2000, and meeting pretty much zero success. My machine is an Acer Aspire 3680 with Intel 945 GM onboard graphics; I have the latest drivers from Acer's website installed, but I can't seem to get any hardware acceleration for OpenGL programs - when I run them, the framerate is about 1 FPS and CPU usage goes through the roof. Using an OpenGL diagnostic program indicated that the current OpenGL driver is Microsoft's generic (software) driver, as opposed to Intel's.

Also FWIW, OpenGL worked absolutely fine on Windows Vista.

What's going on here?

remdul
05-24-2009, 07:11 AM
Intel has always had terrible OpenGL support. Last time I checked they still shipped a short list of games that worked with their hardware/drivers. I guess this may be changing but I'm still steering clear of it, so YMMV.

Have you tried installing the latest graphics drivers?

http://downloadcenter.intel.com/Product_Filter.aspx?ProductID=2115

http://downloadcenter.intel.com/filter_r...s=19&submit=Go! (http://downloadcenter.intel.com/filter_results.aspx?strTypes=all&ProductID=2115&OSFullName=&lang=eng&strOSs=19&submit=Go!)

Gullible Jones
05-24-2009, 10:19 AM
Yup, and those don't work either. Still no hardware acceleration.

I realize that Intel onboard graphics have atrocious OpenGL support. However, they do actually *have* OpenGL support, and in my case that counts for something. On Linux I was actually able to get halfway decent acceleration.