PDA

View Full Version : WGL_ARB_create_context and OpenGL 3.1+



MrKaktus
04-18-2009, 10:17 AM
In this extension specyfication there is said:
(http://www.opengl.org/registry/specs/ARB/wgl_create_context.txt)



The attribute names WGL_CONTEXT_MAJOR_VERSION_ARB and
WGL_CONTEXT_MINOR_VERSION_ARB request an OpenGL context supporting
the specified version of the API. If a version less than or equal to
2.1 is requested, the context returned may implement any version no
less than that requested and no greater than 2.1. If version 3.0 is
requested, the context returned must implement exactly version 3.0.

(Versioning behavior once GL versions beyond 3.0 are defined will
be defined by amending this specification to define dependencies
on such GL versions. It's possible that if version 3.N is
requested and version 3.(N+1) is truly backwards-compatible, a
3.(N+1) context could be returned. But we need to specify
exactly what "backwards-compatible" means given the combination
of deprecated features and forward-compatible contexts.)


Is there any chance to know how 3.1 and future verions will (or should) behave when specyfic version is requested?
When this documentation will be updated?

Thanks,
MrKaktus

Brolingstanz
04-20-2009, 01:05 PM
IMHO the spirit of the existing wording suggests to me that you'll get a feature-compatible version for the version requested, plus or minus the various compatibility issues which are detailed at length in the 3.1 spec (from ARB_compatibility).