PDA

View Full Version : Troubleshooting 32-bit OpenGL app on 64-bit Win



sansan
03-18-2009, 04:14 AM
Dear community!

I am developing a 32-bit OpenGL-based application on 64-bit Windows XP.
Currently I am trying to solve a strange and complicated OpenGL problem related to texturing and involving third-party libs (FreeType2 and FTGL). It seems that it might take me very-very long to find the reason unless I start using some tool like OpenGL debugger.

I have tried an evaluation version of gDebugger but it behaves very strangely on 64-bit WinXP. It looks as if gDebugger is purely 32-bit.

Could you please recommend any tool(s) for debugging OpenGL problems in 32-bit apps on 64-bit Windows XP?

Thanks a lot in advance!

Sergey

ZbuffeR
03-18-2009, 05:19 AM
Did you try GlIntercept ?
No idea how it behaves with 64 bits however.
http://glintercept.nutty.org/

sansan
03-18-2009, 06:13 AM
Yes I did.
It seems to work well, but it can't help me to find the reason why a 2D texture I'm creating is invalid, even glTexImage2D() call fails.

ZbuffeR
03-18-2009, 06:40 AM
Do you have a valid opengl context when you call glTexImage2D ?

sansan
03-18-2009, 06:49 AM
Yes I have. In fact it's FTGL who calls glTexImage2D(), I added a call to wglGetCurrentContext() right before the problematic line and it returned a valid handle.
Moreover, this problematic line works well in 99% cases but in 1% it fails :(
I guess I need to see the entire set of OpenGL state vars at the moment of the call to approach the bug. Probably the fact that I'm inside a display list being GL_COMPILE'd might help somehow...but AFAIK glTexImage2D() should work i.e. it should load the image into the active 2D texture.