PDA

View Full Version : OpenGL 2.1not active



JohnLemus
03-01-2009, 11:19 AM
I have two 9800 GT video cards with the latest driver 182.06 and I have been having a problem with Opengl 3.0. My 3d apps are not recognizing it. Apps like Daz Studio and Poser pro. When I run the Opengl ext viewer it renders to 1.1 with it gets to 2 it crashes.

I have windows xp x64

can any one help

martinsm
03-01-2009, 12:07 PM
Are you using WGL_ARB_create_context to create OpenGL context? Otherwise you wont get v3.0. Without this extension you will get "old" 2.1 context.

JohnLemus
03-01-2009, 04:03 PM
where can I get either 2.1 or 3 for windows xp x64

also where can I get WGL_ARB_create_context

Simon Mihevc
03-02-2009, 01:23 AM
You can access OpenGL extensions with Glew (http://glew.sourceforge.net/).

martinsm
03-02-2009, 01:24 AM
You "get" OpenGL by installing latest video card drivers.
WGL_ARB_create_context is OpenGL extension (http://www.opengl.org/wiki/OpenGL_extensions). You "get" it by loading function manually with wglGetProcAddress, or by using one of cross-platform windowing libraries that will open window and create OpenGL context for you - glfw, freeglut, etc...

JohnLemus
03-02-2009, 06:40 AM
I fixed the problem thank you. I had to go back to a precious version of my drivers. 182.06 is said to support opengl 3.0 but it only ran up to 1.1 so I had to find a set of drivers that came with 2.1

from 182.06 I had to go back to 174

thanks again