PDA

View Full Version : problem about install ForceWare 181.00



tswong
01-19-2009, 09:00 AM
hi all,

i have installed ForceWare 181.00 on my vista 64bit

but the GPU Caps Viewer still shows that the OpenGL version is 2.1.2

i really dont know whats wrong with it. or any thing i missed?

thanks alot!

ZbuffeR
01-19-2009, 09:18 AM
http://developer.nvidia.com/object/nvemulate.html
see "Controlling OpenGL 3.0 and GLSL 1.30 Support"

"With the OpenGL 3.0 / GLSL 1.30 feature set enabled, the driver will export the WGL_ARB_create_context WGL extension string. However, the GL_VERSION string will still show OpenGL 2.1 support. Only when you use the new wglCreateContextAttribsARB() entrypoint to create an OpenGL 3.0 context, then query the version string it will return "OpenGL 3.0"."

tswong
01-19-2009, 07:45 PM
but only before 181.00, nvemulate was needed.
"Before ForceWare 181.00, we had to use NVemulate to enable OpenGL 3.0 support."
see http://www.geeks3d.com/?p=2675

martinsm
01-20-2009, 02:34 AM
NVemulate previously allowed to create OpenGL 3.0 context at all.
181.00 driver allowed to create OpenGL 3.0 context without NVemulate. But anyway - OpenGL version 3.0 is available only when you create OpenGL context in special way (using newly introduced WGL_ARB_create_context). If you use program that does not know this special way (WGL_ARB_create_context extension) and creates context in old way (simply by using only wglCreateContext) then you will not get v3.0 context.