PDA

View Full Version : My game is dark on my computer.



ajm113
12-28-2008, 07:20 PM
This is really wired, my game shows clearly on my wide screen monitor at my other house, but for some reason on my small screen monitor my game looks really dark and I haven't made any changes to the game when transference to the computer with the small monitor.

Is there anything I can do to insure my game will have the correct brightness level on all PCs?

http://img156.imageshack.us/img156/6884/darkjy0.jpg (http://img156.imageshack.us/my.php?image=darkjy0.jpg)

I tried games like Doom3 and see if it had the same issue, but it doesn't look like it. The only thing can popped out of my head is the glColor3f, but I don't think so.

Also, lights are disable, no shaders & I tried Win32 setGamma, nothing is working.

VS2008, C++, Win32, OpenGL, Windows Vista.

dletozeun
12-29-2008, 12:45 PM
Something with blending? Is it as darker as it is now clearing framebuffer color with say, grey?
Are you using the same computer with the two different monitors?

ajm113
12-29-2008, 04:44 PM
Thanks for your reply dletozeun.

I am thinking that now with Enable blend, but I don't know if you say enable or disable blend 2 times or I am thinking it's glBlendFunc.

No I am using 2 different computers and I tried my game on my laptop. For some reason my game shows fine on my laptop, of course lag is appearing, but that's expected.

dletozeun
12-30-2008, 03:40 PM
No I am using 2 different computers and I tried my game on my laptop


Ok, so this is probably not due to your monitor but your hardware and installed drivers. Depending on your hardware and installed drivers it is possible that your program behaves differently. But this kind of issue is often due to a programming mistake with opengl which is more or less visible depending on the implementation.

I am afraid, you have to glance throw your code and find guilty line :)
I have no definite idea of what is causing this kind of problem. I had once a similar problem using fbo, blitting some textures on framebuffer with blending enabled. It looks like that the whole window is multiplied by a grey color, so I suggest to take care of blending setup, and shaders code (if you use them).