PDA

View Full Version : GLSL Version 1.30 not available



McNopper
11-24-2008, 05:10 PM
Hello,

I managed to initialize OpenGL 3.0. Everything works fine besides I can not use GLSL 1.30. E.g. setting "#version 130"
gives an error. Using keywords like smooth gives an error.

Do I somehow need to enable GLSL 1.30? If I query the version, it says 1.30!

I do have the following environment:
- Windows Vista SP 1
- NVIDIA 180.48
- GLEW 1.5.1

Cheers Norbert

Korval
11-24-2008, 06:13 PM
I managed to initialize OpenGL 3.0.

You're using a beta driver. File a bug report on it and move on.

McNopper
11-25-2008, 01:54 AM
Finally I managed to make my code work. The problem was a missing line break in the source of the shader file :o

Groovounet
11-25-2008, 03:11 AM
I managed to initialize OpenGL 3.0.

You're using a beta driver. File a bug report on it and move on.

Common, I'm sure you could be nice sometime ...