PDA

View Full Version : OpenGL 1.4 not supported (mac)



andrewjones
11-11-2008, 03:14 PM
Hope someone can give some info on this?

I have a G4 and a G5. I am using Hexagon 2.5. It works fine on the G5, but not on the G4, which gives the message that OpenGL 1.4 is not supported and may give unpredictable results. Files open one day and then not the next. The card in the G4 is an ATI mac Radeon 9200, which is quite old.

It is difficult to establish which version of OpenGL the macs are using (both are OS 10.4.11), so my question is: is OpenGL 1.4 something to do with the ATI graphics card, and if so, can I fix it?

Thanks in advance for any replies

Mars_999
11-11-2008, 04:41 PM
Are you using the latest drivers?

Radeon 9200 should support GL1.4

Zengar
11-11-2008, 06:48 PM
9200 only supports 1.3 under OS X, as you can see here: http://developer.apple.com/graphicsimaging/opengl/capabilities/GLInfo_1050.html

I am not really sure why, as it also supports shaders and all that stuff, but Apple must have had a reason.

Mars_999
11-11-2008, 08:46 PM
Sad, AFAIK on Windows it supports 1.4. And if it does than Apple didn't allow 1.4 because hardware should be able to do it.

arekkusu
11-11-2008, 09:18 PM
Mars_999, I believe you are mistaken.

Radeon 9200 does not support depth textures, which are required for OpenGL 1.4.

This is not supported in the Windows driver, either.

andrewjones
11-12-2008, 04:34 AM
Thanks for the replies everyone!

It's the Hexagon software that says that OpenGL 1.4 isn't supported, so I assumed that's the version of OpenGL that is built into the Radeon as standard.

Mars_999, I tried to upgrade the drivers, but get this: I cannot persuade the G4 to start in safe boot mode. I have 3 different startup drives on that machine and none of them would kick in, which seems odd, because you would assume that a corrupt system wouldn't be present on all 3 drives at the same time?

Anyway, would Hex not support OpenGL 1.4 because it's a too old version, and if so, is there a way to load a newer version of OpenGL on the Radeon? Or is it time to retire the G4 - I understand I can't upgrade the card to a more powerful model, because it's the biggest one the G4 will accept (according to the sales people anyway) Hey ho!

Mars_999
11-12-2008, 10:29 AM
Mars_999, I believe you are mistaken.

Radeon 9200 does not support depth textures, which are required for OpenGL 1.4.

This is not supported in the Windows driver, either.



Good to know, lesson learned not to trust review sites and spec sheets on hardware either. ;)

Retire the G4, unless you want to try and find a 9700/9800 Radeon card for it.

arekkusu
11-12-2008, 05:26 PM
I guess that depends which review site you look at.

The texture format tables in this comparison of R200 and NV25 (http://www.digit-life.com/articles/gf4/index1.html) make it clear that R200 class cards don't support depth textures, and therefore can't support OpenGL 1.4 (at least, not in hardware.)

arekkusu
11-12-2008, 05:46 PM
@andrewjones:

You can't update the driver for the Radeon 9200 to anything better. Mac drivers come with OS updates, and the driver is already supporting OpenGL 1.3 which is the best that hardware can do.

From Hexagon's web page, it looks like they have "real-time shadow display" as a feature, which I'm guessing really does require OpenGL 1.4. Possibly, you can just not use that feature, and everything else will work fine. I don't know.

Mars_999
11-13-2008, 03:13 PM
http://en.wikipedia.org/wiki/Comparison_..._9xxx.29_series (http://en.wikipedia.org/wiki/Comparison_of_ATI_graphics_processing_units#Radeon _R200_.288xxx.2C_9xxx.29_series)

Wow doesn't seem that long ago that 9000 series was out, man time flies.

andrewjones
11-18-2008, 03:35 PM
Again, thanks for all the replies everyone. Much appreciated.

Mars_999 - I think I'll go look for a 9700/9800 rather than retire the machine. It works beautifully and I hate to bin it just because it's past it's sell-by!

arekkusu: that's a decent thought. I'll try turning off all shading and see what happens. Hex is a modeller, not a renderer so shadows and shading are largely irrelevent.

Incidentally, I found a neat little gizmo called "OpenGL extensions viewer" which makes for interesting reading if any other mac users are going doollally trying to find out what sort of OpenGL they have hidden around and about on their machines...

Once again thanks for the support!