PDA

View Full Version : Problem with an Example from OpenGL SuperBible



andrea77
10-20-2008, 08:29 AM
Dear All,

I am a new user of OpenGL. I have recently bought the 4th Edition of "OpenGL SuperBible". The book is fantastic!

I also downloaded the free code of the book (at: http://www.opengl.org/sdk/docs/books/SuperBible/). However I have a little problem: I tried to compile the project found in Chapter 2 “GLRect” by using Visual C++ 2008 Express. After compiling I get an error “Impossible to find freeglut_static.lib”.

I tried to add this library in the adjuntive dependencies in the Project Properties- Linker-Input Page.

Should I set a path to include special files, like libraries or headers ones?


Thank you in advance for your help.


Andrea

trinitrotoluene
10-20-2008, 12:15 PM
First do you have freeglut (http://freeglut.sourceforge.net/) installed on your system? Search for freeglut.h and/or glut.h header file and freeglut_static.lib (freeglut*.lib,freeglut*.dll,glut*.lib,glut*.dll) library on your system to find in which directories those are and include the fullpath of the files in the correct place for your project settings.

andrea77
10-20-2008, 01:23 PM
Thank you!
I fixed the issue with Freeglut. However I got thsi message "Unable to open the header file'../../shared/gltools.h': No such file or directory".

What does this mean?

Thank you.

trinitrotoluene
10-20-2008, 02:39 PM
Maybe this file is part of a software framework that come with OpenGL SuperBible book. There is a huge source file (http://www.starstonesoftware.net/files/SB-AllSource.zip) at the OpenGL SuperBible book web page. Maybe this file contain your missing header.

andrea77
10-20-2008, 10:52 PM
Hi ,

I solved the problem. One should only ignore the LIBC.lib file. Here is the way:

Just go to "Project Property -> Configuation Properties -> Linker -> Input -> Ignore Specific Library"

Type "LIBC.lib" in the "Ignore Specific Library".