PDA

View Full Version : OpenGL don't work with Trainz on Intel Mobile 965



Intel Mobile 965 Express
09-09-2008, 08:25 AM
I am experiencing a problem with OpenGL in an HP Pavilion laptop with Intel chipset graphic Mobile 965 Express. I can not play Trainz Railroad Sim with OpenGL. I can only play if I apply DirectX, but the quality of graphics and its performance is very poor.
Yesterday I installed from Intel the latest version of the drivers, which was downloaded from the Intel Web site ...
Here paste the xml GPU Caps Viewer report of my card.
Thanks and greetings!
---------------paste--------------------------------------
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<!--************************************************** ********
* GPU Caps Viewer v1.5.2
* (C)2007-2008 Jerome [JeGX] Guinot
* http://www.ozone3d.net/gpu_caps_viewer/
************************************************** *********-->

<gpu_viewer>

<system>
<cpu
name="Intel(R) Core(TM)2 Duo CPU T8100 @ 2.10GHz"
core_speed_mhz="2094"
num_cores="2"
family="6"
model="7"
stepping="6"
/>
<memory
megabytes_physical_amount="2037"
/>
<operating_system
description="Windows Vista ver.6.0 build 6001 [Service Pack 1]"
directx_version="10.0"
physx_version="0"
/>
</system>
<graphics_controller>
<renderer
model_from_ogl="Intel 965/963 Graphics Media Accelerator"
model_from_drivers="Mobile Intel(R) 965 Express Chipset Family"
device_description="Mobile Intel(R) 965 Express Chipset Family"
adapter_string="Mobile Intel(R) GMA X3100"
vendor="Intel"
vendor_id="32902"
device_id="10754"
drivers="7.15.10.1537 - Mobile Intel(R) 965 Express Chipset Family"
video_memory_size_megabytes="448"
bios_string="Intel Video BIOS"
cur_display_mode="1280x800 @ 60 Hz - 32 bpp"
/>
<opengl_caps
opengl_version="53363436"
glsl_version="1.10 - Intel Build 7.15.10.1537"
arb_texture_units="8"
vertex_texture_units="16"
pixel_texture_units="16"
geometry_texture_units="0"
max_texture_size="2048"
anisotropy="0"
point_sprite_size="0"
num_dynamic_lights="16"
max_viewport_size="2048"
max_vertex_uniform_components="512"
max_fragment_uniform_components="1024"
max_varying_float="41"
max_vertex_bindable_uniforms="0"
max_fragment_bindable_uniforms="0"
max_geometry_bindable_uniforms="0"
fbo="yes"
max_mrt_draw_buffers="7"
pbo="yes"
s3tc="yes"
ati_3dc="no"
texture_rectangle="yes"
floating_texture="no"
/>
<opengl_extensions num_extensions="69" >
<extension name="GL_EXT_blend_minmax" />
<extension name="GL_EXT_blend_subtract" />
<extension name="GL_EXT_blend_color" />
<extension name="GL_EXT_abgr" />
<extension name="GL_EXT_texture3D" />
<extension name="GL_EXT_clip_volume_hint" />
<extension name="GL_EXT_compiled_vertex_array" />
<extension name="GL_SGIS_texture_edge_clamp" />
<extension name="GL_SGIS_generate_mipmap" />
<extension name="GL_EXT_draw_range_elements" />
<extension name="GL_SGIS_texture_lod" />
<extension name="GL_EXT_rescale_normal" />
<extension name="GL_EXT_packed_pixels" />
<extension name="GL_EXT_separate_specular_color" />
<extension name="GL_ARB_multitexture" />
<extension name="GL_EXT_texture_env_combine" />
<extension name="GL_EXT_bgra" />
<extension name="GL_EXT_blend_func_separate" />
<extension name="GL_EXT_secondary_color" />
<extension name="GL_EXT_fog_coord" />
<extension name="GL_EXT_texture_env_add" />
<extension name="GL_ARB_texture_cube_map" />
<extension name="GL_ARB_transpose_matrix" />
<extension name="GL_ARB_texture_env_add" />
<extension name="GL_IBM_texture_mirrored_repeat" />
<extension name="GL_EXT_multi_draw_arrays" />
<extension name="GL_NV_blend_square" />
<extension name="GL_ARB_texture_compression" />
<extension name="GL_3DFX_texture_compression_FXT1" />
<extension name="GL_EXT_texture_filter_anisotropic" />
<extension name="GL_ARB_texture_border_clamp" />
<extension name="GL_ARB_point_parameters" />
<extension name="GL_ARB_texture_env_combine" />
<extension name="GL_ARB_texture_env_dot3" />
<extension name="GL_ARB_texture_env_crossbar" />
<extension name="GL_EXT_texture_compression_s3tc" />
<extension name="GL_ARB_shadow" />
<extension name="GL_ARB_window_pos" />
<extension name="GL_EXT_shadow_funcs" />
<extension name="GL_EXT_stencil_wrap" />
<extension name="GL_ARB_vertex_program" />
<extension name="GL_EXT_texture_rectangle" />
<extension name="GL_ARB_fragment_program" />
<extension name="GL_EXT_stencil_two_side" />
<extension name="GL_ATI_separate_stencil" />
<extension name="GL_ARB_vertex_buffer_object" />
<extension name="GL_EXT_texture_lod_bias" />
<extension name="GL_ARB_occlusion_query" />
<extension name="GL_ARB_fragment_shader" />
<extension name="GL_ARB_shader_objects" />
<extension name="GL_ARB_shading_language_100" />
<extension name="GL_ARB_texture_non_power_of_two" />
<extension name="GL_ARB_vertex_shader" />
<extension name="GL_NV_texgen_reflection" />
<extension name="GL_ARB_point_sprite" />
<extension name="GL_EXT_blend_equation_separate" />
<extension name="GL_ARB_depth_texture" />
<extension name="GL_ARB_texture_rectangle" />
<extension name="GL_ARB_draw_buffers" />
<extension name="GL_ARB_pixel_buffer_object" />
<extension name="GL_WIN_swap_hint" />
<extension name="GL_EXT_framebuffer_object" />
<extension name="WGL_ARB_buffer_region" />
<extension name="WGL_ARB_extensions_string" />
<extension name="WGL_ARB_make_current_read" />
<extension name="WGL_ARB_pixel_format" />
<extension name="WGL_ARB_pbuffer" />
<extension name="WGL_EXT_extensions_string" />
<extension name="WGL_EXT_swap_control" />
</opengl_extensions>
</graphics_controller>
<graphics_drivers>
<driver url="http://www.geeks3d.com/?page_id=752&from-gpu-caps-viewer" />
</graphics_drivers>
<graphics_cards_reviews>
<review url="http://www.geeks3d.com/?cat=3&from-gpu-caps-viewer" />
</graphics_cards_reviews>

</gpu_viewer>
------------------end paste----------------------------------

ZbuffeR
09-09-2008, 09:03 AM
opengl_version="53363436" -> either a big bug from GPU Caps Viewer, or a bug in your driver... OpenGL versions are more like 1.1.0, 1.5, 2.1.0 , 3.0 ...

Michael Gold
09-09-2008, 09:32 AM
I'm guessing that's the address returned by GetString. Its a pointer to the version number in ascii, not a numerical value.

zed
09-09-2008, 07:00 PM
according to
http://en.wikipedia.org/wiki/Intel_GMA

Mobile Intel(R) GMA X3100 doesnt support gl2.0, but the above info seems to suggest it does?
Should I change the wiki entry?


but the quality of graphics and its performance is very poor.the quality should be ok, but even if u get it running with opengl, performance will most likely be as bad as it is with directx, due to it being an intel graphics chipset, if youre concerned about graphics speed, get a laptop with a geforce go or radeon mobility chipset it (research beforehand).

try running in a smaller window,disabling AA, etc to boost framerate