PDA

View Full Version : lib3ds SuSE 11.0 and YAST



jerryyyyyy
08-05-2008, 09:31 AM
Well, in the latest incarnation of the flight simulation software we use in our research, I have to move yet again to another Linux platform (It does beat SGI). This time it is SuSE and I am using the latest 11.0. I thought perhaps in this new version I could use YAST to install the lib3ds libraries I need. So I found lib3ds-1-3 and lib3ds-devel labeled "Import and export of Autodesk 3DS" and installed them.

Alas, when I make the file the library in not found: /usr/local/lib/lib3ds.a.

I have been here before and scoured the /usr libraries and could not find the sucker.

So I went to sourceforge and downloaded the lib3ds-1.3.0.zip, unzipped and tried to run the configure shell.

Alas, when it runs the configure it checks the C compiler, which it find and compiles test program (a.out) but the test program does not run..... in the config.log it says Permission denied.

I am running as root.

Aha, maybe it is the funny security system around now in Linux that is preventing this. I will look around but if anyone has any bright ideas I would appreciate it. Wheneven I have to redo this system I check in here... seems like every two years.

dletozeun
08-05-2008, 09:51 AM
Your problem is by far not related to opengl, you will find more answers about more general forums.

anyway, even though you are root, that doesn't mean that all required files are readable or the executable executable; but you may change permission easily.

jerryyyyyy
08-05-2008, 11:01 AM
Merci, j'ai essaye de changer les permission mais avec le meme resultat. La solution est simple mais pas evident a moi....

jerryyyyyy
08-05-2008, 03:47 PM
The solution was that the file was on a shared Windows disk and it would not write to that. For the record.

Dark Photon
08-07-2008, 05:41 AM
Linux...SuSE...use YAST to install the lib3ds libraries I need. So I found lib3ds-1-3 and lib3ds-devel...installed them....Alas, when I make the file the library in not found: /usr/local/lib/lib3ds.a ... I...scoured the /usr libraries and could not find the sucker

Try:
rpm -ql lib3ds
rpm -ql lib3ds-devel

Of course, YaST will tell you too. Just click the file list tab.