PDA

View Full Version : OpenGL Glide wrapper. Unpupported extension.



psycoshot
07-11-2008, 09:39 PM
Hello,

I want to use a glide wrapper to play diablo 2. When I installed it all I could get was a black screen (glide test and game) I still had sound though.

I found that

WGL_ARB_render_texture
is the extension I need to solve this problem.

When I query my OpenGl I get:

Renderer: Mesa DRI 2000
20060602 AGP 8x
video-memory: 64mb

max.texture-size: 2048x2048

unsupported extensions:
WGL_ARB_render_texture

What can I do to enable this extension??

Also, I have an ATI radeon 9200
and I run diablo on WINE in kubuntu (linux)

Need any more info?

I'll take any suggestions you have,

Cheers,

sqrt[-1]
07-12-2008, 12:49 AM
The "WGL" extensions are "Windows openGL" extensions. According to this:
http://archives.free.net.ph/message/20070727.153322.bda25be2.en.html

WINE only provides support for this extension in version 0.9.42

If you installation of kubuntu is more than a year old (with no updates) you will not have support for it. (perhaps update WINE?)

psycoshot
07-12-2008, 09:26 AM
My wine is at v1 right now.
I'll try running all my upgrades (its been about a month)

If not I could try downgrading wine.

Thanks

danimalhanke
07-12-2008, 02:42 PM
goto http://www.guru3d.com then their download page and get riva tuner. install it and in the driver setting area open second drop down box select opengl icon then play with setting. it's how I got my Chronicles of riddick to play. rivetuner has many setting to look at. give it a try.

Zengar
07-12-2008, 05:18 PM
goto http://www.guru3d.com then their download page and get riva tuner. install it and in the driver setting area open second drop down box select opengl icon then play with setting. it's how I got my Chronicles of riddick to play. rivetuner has many setting to look at. give it a try.

Since when rivatuner has linux support?

psycoshot
07-12-2008, 05:48 PM
]The "WGL" extensions are "Windows openGL" extensions. According to this:
http://archives.free.net.ph/message/20070727.153322.bda25be2.en.html

WINE only provides support for this extension in version 0.9.42

If you installation of kubuntu is more than a year old (with no updates) you will not have support for it. (perhaps update WINE?)

YOU ARE GOD

It works ^^ Thanks

psycoshot
07-12-2008, 05:48 PM
goto http://www.guru3d.com then their download page and get riva tuner. install it and in the driver setting area open second drop down box select opengl icon then play with setting. it's how I got my Chronicles of riddick to play. rivetuner has many setting to look at. give it a try.

Since when rivatuner has linux support?

It doesn't XD

It didn't work on wine either.

psycoshot
07-12-2008, 06:50 PM
I think I need to cry. I spent 30+ hours trying to get a glide wrapper, and now that it works, it gives shitier performance.

jose1
08-17-2008, 02:38 PM
Hi,

I'm sort of in the same situation. I want to play Diablo II but I just get a black screen. WGL_ARB_render_texture is not supported according to the wrapper.

The only other version of wine available (through synaptic) on Hardy is wine 9.59, which I already tried and still (apparently) does not support the WGL_ARB_render_texture extension. Could you please elaborate (in noob speech) on how you got yours to work?

Thanks, all help appreciated.

PaladinOfKaos
08-18-2008, 03:01 PM
If you do _anything_ with wine in Ubuntu/Kubuntu, add the winehq repository. You'll be up-to-date with the latest enhacements.

Technically, that repository is on the development branch (1.1), but I haven't seen any stability issues in my use (which is mostly Diablo II and Baldur's Gate II).

The URL is Here (winehq.org) (http://www.winehq.org/site/download-deb)

EDIT: Just for the record, I'm using a GLIDE wrapper in Diablo II without issue right now. I can check which one I'm using when I get home in a few hours. I'm using it to fix the screen-offset bug that D3D mode has. If you don't have that (or any other) glitch in D3D mode, I suggest D3D mode. GLIDE is limited to 16-bit color, and can't do all the effects that D3D mode can.

jose1
08-19-2008, 10:16 AM
Nevermind....

I just realized that the problem wasn't wine. I just tried another wrapper (for some reason I thought there was only one) and it works just fine.

Performance, however, is much better with glide. I don't know if this is due to the limitations that you mention, still looks good though.

Thanks.