PDA

View Full Version : no vertex/fragment shader extensions on 9600XT under linux



snowman
03-20-2005, 06:34 AM
Hello I am using linux and have AT9600XT video card
but when i retreive extensions using glGetString(GL_EXTENSIONS) i cannot find ARB_vertex_shader and ARB_fragment_shader
glew library also says that there aro no such extensions

i use proprietary linux driver from ati.com
what could be a problem in

Humus
03-20-2005, 04:15 PM
What output do you get if you run fglrxinfo?

snowman
03-21-2005, 01:04 AM
I am not at home now but as far as I remember there was soething about ATI Technologies ....
but last time it was saying something like Mesa...
but fglrx module was loaded and used, there wasn't any module like radeon

Humus
03-22-2005, 04:28 PM
Well, it should read "ATI Technologies" of course, but it's also of interest of what driver version number it shows in case the latest driver didn't install properly or something and you're still running an old driver.

snowman
03-23-2005, 10:11 AM
here is output of fglrxinfo
---
[sergey@celestia sergey]$ fglrxinfo
Loading required GL library /usr/lib/libGL.so.1
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org (http://www.mesa3d.org)
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
---

and here is piece of lsmod output
---
fglrx 226012 0
agpgart 31016 0
---

for some reason fglrx is not used but even when it was used and even with nvidia-agp(i have motherboard with nforce2 chipset) module output of fglrxinfo was the same
---

I know that fglrx rpm package has its own libGL, so i reinstalled it but have same result.