PDA

View Full Version : GLEW and GLSL -- linker errors



cutting_crew
01-13-2005, 12:19 PM
hi all.. i am trying to do a little GLSL while i take a break from my terrain project and i keep getting the following linker errors:

i am using vc6 and i have the glew.dll in my system32 folder and the glew32mx.lib added to my link tab in setting in vc6. what am i doing wrong? i know i should go ahead and get OGL 2.0 so i wont have to use extensions anymore. hehe.

--------------------Configuration: glutglsl - Win32 Debug--------------------
Linking...
glutglsl.obj : error LNK2001: unresolved external symbol __imp____glewUseProgramObjectARB
glutglsl.obj : error LNK2001: unresolved external symbol __imp____glewLinkProgramARB
glutglsl.obj : error LNK2001: unresolved external symbol __imp____glewAttachObjectARB
glutglsl.obj : error LNK2001: unresolved external symbol __imp____glewCreateProgramObjectARB
glutglsl.obj : error LNK2001: unresolved external symbol __imp____glewCompileShaderARB
glutglsl.obj : error LNK2001: unresolved external symbol __imp____glewShaderSourceARB
glutglsl.obj : error LNK2001: unresolved external symbol __imp____glewCreateShaderObjectARB
glutglsl.obj : error LNK2001: unresolved external symbol __imp____GLEW_ARB_fragment_program
glutglsl.obj : error LNK2001: unresolved external symbol __imp____GLEW_ARB_vertex_program
glutglsl.obj : error LNK2001: unresolved external symbol __imp__glewInit
Debug/glutglsl.exe : fatal error LNK1120: 10 unresolved externals
Error executing link.exe.

glutglsl.exe - 11 error(s), 0 warning(s)