PDA

View Full Version : OGLSL linking -> Exception during compilation



Guido
02-08-2005, 05:01 AM
I'm writing a physical simulation on GPU using OGLSL. The vertex and fragment program compilation works fine but the linking step ( glLinkProgramARB ) takes a really long time ( 15 minutes...) and, when the virtual memory doesn't "finish" first, gets back the message "C9999: ****exception during compilation****"...

Even if there is a really hight probability of my personal errors however this thing doesn't seem to me a fully natural behaviour...

I have a 6800 GT with the 71.80 Nvidia's driver...

Some suggestions????

Guido

Relic
02-08-2005, 06:41 AM
this thing doesn't seem to me a fully natural behaviour Nicely put. :)
See here how to report to NVIDIA:
http://www.opengl.org/discussion_boards/cgi_directory/ultimatebb.cgi?ubb=get_topic;f=11;t=000602

yooyo
02-08-2005, 07:56 AM
Nvidia compile shaders during linking. This is reason why glCompile... works.

Why app crash during linking... I dont know. I dont have such problems and I have 6800 GT + 71.80. Maybe if you post your shaders here, or piece of code from your app that shows how you do compiling and linking shaders.

yooyo

Guido
02-09-2005, 06:07 AM
thanks relic...Nvidia has recognized it has own compiler's problem...

samueleagle
02-12-2005, 05:21 PM
Not all features of GLSL are supported by currently avaible ATI/nVidia cards. As I know, gl_FrontFacing, noise1/2/3/4, etc, are not supported by X800 serious nor nVidia 6X series.

For complete support of GLSL, maybe we should count on cards in the future.