PDA

View Full Version : How to Update GL Version from 1.4 to 2.0?



LLM
06-05-2006, 01:54 AM
My system is WinXp, and I use VC++6.0.My OpenGL Version is 1.4(use glew).How could I update my system to OpenGL 2.0.And How can I use GLSL in VC++6.0 environment.

LLM
06-05-2006, 03:17 AM
I can't find gl_FragColor and uniform and so on in my glew.h why?

ZbuffeR
06-05-2006, 06:17 AM
>> gl_FragColor and uniform
Those are keywords used within glsl shaders, it is not OpenGL C code, but part of the string of a shader you pass to opengl.

Read the tuts here :
http://www.lighthouse3d.com/opengl/glsl/index.php?ogloverview

LLM
06-05-2006, 08:54 AM
Thanks. That is what I need.