PDA

View Full Version : Activating GLSL extensions in ForceWare 56.53 & 56.54 drivers



ricar6
01-30-2004, 10:30 AM
It seems that there is a 'problem' in this forums as the previous thread (with its 15 posts) about this has disappeared... Maybe the problem is that the moderator is working or making favours to NVIDIA.

I repeat the previous text:


In WinXP, under
HKEY_LOCAL_MACHINE -> SOFTWARE -> NVidia Corporation -> Global
You have to create a new key called OpenGL
Under OpenGL create a new key called Debug
Under Debug create a DWORD value called ShaderObjects and set it to 1 if you want those extensions to be exposed.
Also, if you want that the driver creates a file with the assembly output you can create a DWORD value (under Debug) called WriteProgramObjectAssembly and set it to 1
I have discover those values myself so I don't know if there are other posibilities.

The implementation is very buggy and lacks some basic features, like ftransform(), ...

Korval
01-30-2004, 11:40 AM
The implementation is very buggy and lacks some basic features, like ftransform(), ...

Which, not incidentally, may be the reason you have to hack the registry in order to use it http://www.opengl.org/discussion_boards/ubb/wink.gif

Zengar
01-30-2004, 12:49 PM
I guess it's my fault that it was erased ... Sorry

LarsMiddendorf
01-30-2004, 03:03 PM
Is there a way to get the assembly output of the glSlang compiler on ATI cards? It would be really helpfull to know why some shader don't work correctly.

Zengar
01-30-2004, 03:32 PM
The idea of glslang is to compile to the native assembly, bypassing the extensions. As nvidia uses it's united sahder compiler in the driver(which optimisations are very very impressive), it may have no difference if they compile it to NV_fp extensions. I don't know if it is also true with ATI.
Anyway, my message doesn't make any sence.
Maybe I'm simply drunk(enjoing the party with my friends http://www.opengl.org/discussion_boards/ubb/smile.gif ). Sorry for inconveniance.

Luckily yours Zengar