PDA

View Full Version : NVshaderPerf bug



k_szczech
02-28-2007, 12:00 PM
Just tried it for a set of 10 GLSL shaders.
Everything works fine except for G70-GT profile, which produces malformed output file.
For every shader it produces assembly code that seems correct (both cg and intenal compiler) but for every shader it states: "Error compiling shader".
I've uploaded output file to:
http://ks-media.ehost.pl/opengl_org/results7800GTX.txt
Look at the end of the file. I've runned nvshader perf 3 times - always the same result.

command line used for G70-GT profile:
nvshaderperf.exe -o results7800GTX.txt -a G70-GT shaders/*.glsl

and this is command line for 7800GT - works fine:
nvshaderperf.exe -o results7800GT.txt -a G70 shaders/*.glsl

Anyone else bumped into this?

Jeff Kiel
03-01-2007, 06:25 PM
Hello! I am the developer of NVShaderPerf and would like to help you resolve the issue. The best thing is if you can send me the source shader. Please feel free to contact me at NVShadefPerf@nvidia.com

Thanks!
Jeff

k_szczech
03-02-2007, 04:27 AM
The best thing is if you can send me the source shaderIt's actually all 10 shaders that have the same problem. All of them only under G70-GT. And these are shaders that actually work on real hardware (tested on GPU's starting from Radeon9550 up to GeForce7800GT). I'll send it as soon as I get back home.
I've also noticed there is no message when instruction count is exceeded.

Jeff Kiel
03-02-2007, 07:20 AM
OK, even one example would help. Without an exmple, it is hard to determine anything.

Excuse the typo in the previous email, just typing too fast ;)