PDA

View Full Version : GLFW fullscreen defaults to 60fps always



soconne
01-11-2004, 08:23 PM
I cannot figure out why GLFW is defaulting to using VSync when I go to fullscreen mode. My frame rate stays at a constant 60 fps even when I manually turn VSync off in my display properties. I'm using a Radeon 9800 Pro. And it is not doing this when I'm in window mode, only in fullscreen. Any ideas?

osiukas
01-12-2004, 06:33 AM
Did you turn off OpenGL vertical sync?

soconne
01-12-2004, 01:21 PM
Yes, that's what i meant above. "OpenGL" Vsync is what I turned off.

marcus256
01-13-2004, 03:18 AM
Because in fullscreen mode GLFW changes the video mode, and the refresh rate used is the default refresh rate (which is 60 Hz on most Windows systems). Either:

A) Change the default refresh rates (e.g. check nvidia display options)

B) Use glfwOpenWindowHint( GLFW_REFRESH_RATE, my_desired_rate )

In windowed mode the refresh rate is the same as that for the desktop (i.e. your current desktop setting).