PDA

View Full Version : Transfering OpenGL drivers across hard drives



dlslim
01-15-2004, 11:02 PM
I'm not necessarily new, but I am running into a brick wall regarding my OpenGL applications on my computer. I am running Windows XP Professional and my C drive only holds 8 GB, so I installed a second hard drive which holds 30 GB. I've been installing all of my OpenGL applications on this drive, but when I try to access those programs or games, I get the same error message:

JA: v1.0.1.0 win-x86 Oct 24 2003
Initialising zone memory .....
----- FS_Startup -----
Current search path:
E:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets3.pk3 (16 files)
E:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets2.pk3 (62 files)
E:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets1.pk3 (8320 files)
E:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets0.pk3 (15346 files)
E:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData/base

----------------------
23744 files in pk3 files
execing default.cfg
couldn't exec jaconfig.cfg
couldn't exec autoexec.cfg
...detecting CPU, found AMD w/ 3DNow!

------- Input Initialization -------
Skipping check for DirectInput
Joystick is not active.
------------------------------------
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
--- Common Initialization Complete ---
Working directory: E:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData
Initializing OpenGL subsystem
...initializing QGL
succeeded
...setting mode 4: 800 600 FS
...using desktop display depth of 32
...calling CDS: ok
...registered window class
...created window@0,0 (800x600)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 8 )
...23 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 32, 24, 0 )
...23 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (4)
...setting mode 3: 640 480 FS
...using colorsbits of 16
...calling CDS: ok
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...23 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...23 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
----- CL_Shutdown -----
-----------------------
GLW_StartOpenGL() - could not load OpenGL subsystem

Is there a way that I can transfer my OpenGL drivers and settings to the second hard drive?

Relic
01-23-2004, 05:17 AM
This normally happens if there is no hardware accelerated OpenGL pixelformat found.
Deinstall and reinstall the graphics driver.

dlslim
01-23-2004, 02:15 PM
I've uninstalled and reinstalled the video drivers more than once and the same thing continues to happen. My OpenGL applications work on my C drive but not my E drive.